1

This question already has an answer here:

I've always found this feature quite annoying and when I try to turn it off or simply just clear the password it still prompts me for a password. Everytime I've done that I've had to reinstall ubuntu all over again because nothing I put in will work. It keeps asking for authentication on EVERYTHING!! I can't even do a simple search of MY OWN FILES AND PROGRAMS without being prompted for a password.

I did a format and reinstall recently and I didn't have this problem until something popped up asking for my password for a keyring. I saw this A LOT before I reinstalled but it wouldn't let me install some software I needed until I did. Ever since, this stupid keyring thing is ALWAYS asking for a password.

marked as duplicate by Panther, Braiam, Aditya, Warren Hill, Jorge Castro Nov 15 '13 at 15:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

If you use auto-login and your keyring password is different than your login password you can remove the keyring password in „Passwords and Encryption Keys“:

Passwords and Encryption Keys

There should be entries listing different passwords. Right click there and change the password. If not, check the settings:

screenshot

For using sudo without being prompted for a password, you might use an USB Flash Drive USB Flash Drive for authentication:

 apt-get install libpam-usb pamusb-tools
 pamusb-conf --add-device YourUSB
 pamusb-conf --add-user Username
  • I just tried that. There were only two records there and neither had the password I use for keyring. In fact, one had a password I don't even recognize and have never used (as far as I know). Its really long and looks like this %00%00%00%01%00%00%00%0C – user212178 Nov 14 '13 at 22:59
  • Could you enable "by keyring" and "Show any"? – user203053 Nov 15 '13 at 0:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.