I have been using the Vasco smartcard reader since quite some time. Already in Ubuntu 13.04 I was experiencing some problems (I always had to plug it out and in again to make it work). Now, I have upgraded to Ubuntu 13.10 it does not work at all anymore. (opensc-tool -a returns no smart card readers).

When I plug it in, the green led is on for a few seconds and then it goes out again.

The kernel still recognizes it. The output of lsusb is: Bus 008 Device 014: ID 1a44:0001 VASCO Data Security International Digipass 905 SmartCard Reader

I have verified on an old Ubuntu 10.04 the smart card reader is still working.

  • It has worked with Xubuntu 13.10.
    – cavila
    Jan 9, 2014 at 22:51

6 Answers 6


Tried the solution provided in "best answer" and I do confirm it works! (current system: Ubuntu 14.04).

I've also tried the same but starting the pcscd deamon in "normal" mode (daemon running in background) and it works as well.

To summarize, when you need to use your VASCO reader, do the following:

a) unplug it if it was plugged on the computer and all leds are off (green led on means reader working ok!)

b) in a Terminal, run the following command:

sudo service pcscd stop

c) then, run the following one:

sudo service pcscd start

d) (very) quicky after, plug your VASCO reader in an usb slot.

If you see its green led lighting up, it worked. Plug an eid card and do whatever you need to...


I suppose I have the same problem.

It seems to work when I first run pcscd -f and the quickly plugin the reader.

  • Yes, I noticed this as well :)
    – Paul Praet
    May 26, 2014 at 15:18

It seems it was related to an unstable version of pcscd which sometimes crashes...


Still having the issue with 13.10... pcscd segfaulting at startup and card reader not working.

$ lsusb
Bus 003 Device 006: ID 1a44:0001 VASCO Data Security International Digipass 905 SmartCard Reader


$ dmesg | grep -i error
[   35.770385] pcscd[1540]: segfault at 7f1ded71c198 ip 00007f1ded71c198 sp 00007f1ded70ce70 error 14 in libc-2.17.so[7f1dedb3e000+1bd000]

When starting pcscd manually...

~$ sudo pcscd -f
00000000 ccid_usb.c:569:OpenUSBByName() Can't claim interface 3/6: -6
00000146 ifdhandler.c:117:CreateChannelByNameOrChannel() failed
00000017 readerfactory.c:1009:RFInitializeReader() Open Port 0x200000 Failed (usb:1a44/0001:libudev:0:/dev/bus/usb/003/006)
00000008 readerfactory.c:312:RFAddReader() VASCO DP905v1.1 init failed.
00000037 hotplug_libudev.c:384:HPAddDevice() Failed adding USB device: VASCO DP905v1.1
00000013 utils.c:95:CheckForOpenCT() File /var/run/openct/status found. Remove OpenCT and try again

I have the same problem on Ubuntu 14.04.

It seems to work when I run sudo modprobe -r pn533 and restart service by sudo service pcscd restart.

After research about why we have to disable pn533, I find out this link from ArchLinux wiki about Touchatag RFID Reader.

As article said, we should disable pn533 and nfc driver in kernel by

# echo "install nfc /bin/false" >> /etc/modprobe.d/blacklist.conf
# echo "install pn533 /bin/false" >> /etc/modprobe.d/blacklist.conf

In my case, it seems the problem is the kernel power-management/auto-suspend. Looks like it fails to resume the device.

To fix this, I've disabled the auto-suspend for this device. Here is how:

1 - CCID version >= 1.4.28 or fix the "/lib/udev/rules.d/92-libccid.rules" file like in commit 00aed9f

2 - create the rule file


ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="1a44", ATTR{idProduct}=="0001", TEST=="power/control", ATTR{power/control}="on"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.