2

I've installed a fresh Ubuntu 12.04.3 64bit and all current updates! And then installed the solr-jetty package, which I'm using successfully on Ubuntu for several month now. But it is not working anymore. The Jetty is starting but the Solr Server is not working. I've looked into the Log:

432 [main] ERROR org.mortbay.log - Error starting handlers
java.lang.NoClassDefFoundError: org/apache/commons/fileupload/FileItemFactory
at org.apache.solr.servlet.SolrRequestParsers.<init>(SolrRequestParsers.java:92)

I tried to get Solr manually running with Tomcat, but I get the same error. Any idea? Thanks

2

It's because an update came out literally this morning (11/14/13) that Jetty has problems with.

apt-get install libcommons-fileupload-java:amd64=1.2.2-1

That'll downgrade it and that error should go away after you restart the Jetty service.

  • You are my hero! Thanks a lot. It works again. Just one thing more: How do I pin this Version because Ubuntu is know immediatly trying to install the newer version? – Fabi Kirstein Nov 15 '13 at 8:43
  • Hold it with apt-mark hold libcommons-fileupload-java:amd64. – Ari Velazquez Nov 15 '13 at 18:25
  • (And for what it's worth, replace hold with unhold to unhold it!) – Ari Velazquez Nov 15 '13 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.