6

I have a fresh ubuntu 13.10 install and a dual-monitor setup. I can't get the setup working propely because the monitor settings get reverted every time I reboot.

How do I fix this?

Note that I get the initial settings when I start nvidia-settings after a logout/reboot.

6

Okay I got it working: You have to change the display settings in system settings -> display as well.

Now everything works like a charm!

  • what you did pls elaborate – Edward Torvalds Mar 22 '15 at 11:19
  • Very simple and made the trick. Thanks brother! – Martin Pfeffer Oct 24 '15 at 3:20
3

The only solution for me was dconf-editor, and search for xrandr using Ctrl-F.

Disable the following keys:

org.cinnamon.settings-daemon.plugins.xrandr.active = false
org.gnome.settings-daemon.plugins.xrandr.active = false

Remove the old monitors.xml:

rm ~/.config/monitors.xml

Then setup the montiors with sudo nividia-settings. After that apply settings and save Xorg.conf to /etc/X11/xorg.conf.

Reboot, and it should work.

  • unfortunately I cannot see xrandr anymore in ubuntu18.04, can it be harcoded now? – Wang Apr 14 at 13:43
  • there is no xrandr plugin any more setting that to false has no effect. And there is a new bug, monitors.xml is also ignored. You have to use command line tools to setup in .xinitrc – Wang Apr 14 at 18:34
2

Add nvidia-settings --load-config-only (see man page) to your startup programs, that should apply your settings each time you login.

What's happening here is that nvidia-settings correctly saves your settings to ~/.nvidia-settings.rc, but can't reapply them after a restart unless run. Since you probably don't want to see its window every time you login, the --load-config-only switch tells it to load the existing config, apply it and exit.

  • I tried that, unfortunately it doesn't help. With Ubuntu 13.10 nvidia-settings -l get's automatically written to the Session Manager. Also rerunning nvidia-settings shows me a fresh config, where all my settings have been resettet. – machete Nov 14 '13 at 15:51
1

I solved this problem with following steps.

mv ~/.config/monitors.xml ~/.config/monitors.xml.bak

That monitors.xml overrides xorg.conf every time reboot.

sudo nvidia-settings

then set you want, save the file to /usr/share/X11/xorg.conf.d/xorg.conf

That's it. This should solve your problem.

  • This is not going to work ... gnome will use default monitor setting and ignore your xorg.conf completely – Wang Apr 14 at 18:32
1

It could be that lightdm is overriding you setting. See this answer here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.