2

I have 5 web app projects in my local machine with Ubuntu 12.04 installed on it. Everything was good, but today when I started a new project with symphony, I found that I should upgrade php to 5.4.x, so I did it and upgraded to apache2 too. After these updates I restarted my PC [for some reasons] and now I see a 403 forbidden page (from apache2 web-server) for all of my projects.
I didn't change permissions or the Apache virtual host configuration, nothing and nothing. Just after restart I see 403 forbidden!

  • I'm beginner in Ubuntu so if you want any information about users, groups, or... please say how can I find it for you, thanks
  • I tried to change the whole web-root directory permission to 777 and change user:group to www-data or root, but nothing happened.
  • APACHE 2.4.6
    PHP 5.5.5-1
  • example, this is the thenetmoon project and it was done with symfony, but apache can't access the web folder :

    enter image description here
  • With the packaged version of Apache an error like this would mean that www-data can't access that particular folder. You are using a non packaged version of Apache, thus I'd say you might have not configured it properly. Since you are a beginner I'd advise you to uninstall Apache 2.4.6 and install the packaged version (2.2.22). – Luís de Sousa Nov 14 '13 at 8:17
  • @LuísdeSousa : thank you for quick answer, but i update it with apt-get. i can't understand whats the mean of packaged version. thank you so much – Netmoon Nov 14 '13 at 11:15
  • By "packaged version" I mean that available from the official repos. You can check it here: packages.ubuntu.com/… Good thing that you solved it. – Luís de Sousa Nov 15 '13 at 9:26
3

finally I found what happened. after reading about apache 2.4.*, I have changed APACHE Configuration file. so I added this line in <Directory> scope:
Require all granted
and after that, sudo service apache2 restart , and now everything goes fine.

Here is the Apache documentation relevant for this fix: http://httpd.apache.org/docs/2.4/upgrading.html#access

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.