I've searched for people with similar problems but none of the fixes seem to be working for me.

I have a Windows 7 (200gb + 100mb reserved partitions) and the rest (~800gb) as unallocated. This is how it's represented in Windows and miniPartitionWizard/EasyBCD, both of which I have used (as advised elsewhere) to edit/repair the partitions and attempt to repair the MBR.

When I boot from the 13.1 live-usb and view the disk with gparted I get this prompt:

/dev/sda contains GPT signatures, indicating that it has a GPT table. However it does not have a valid fake msdos partition table, as it should. Perhaps it was corrupted -- possibly by a program that doesn't understand GPT partiotn tables. Or perhaps you deleted the GPT table, and are now using an msdos partition table. Is this a GPT partition table?

Both y & n have the same results of showing the disk as completely unallocated, though.

If I say no, I get the additional error

No partition table found on device /dev/sda

If I try and create a new partition, which is expected.

In terminal sudo parted -l throws the same error. I've tried reinstalling Windows several times, even if I don't change the partitions at all the Windows installation doesn't show in gparted. Am I missing something here?

1 Answer 1


It is entirely possible that your disk has stray GUID partition table data (in this case, Windows will actually still boot happily, recognizing the disk as only MBR). Is your Windows installed in legacy BIOS mode?

To confirm this, from the Ubuntu Live Desktop environment, open a Terminal and install gdisk (ensure you have network connectivity):

sudo apt-get install gdisk

Then list partitions that are on the GUID partition table:

sudo gdisk -l /dev/sda

Chances are, it might have come up empty. In that case, you will need to preserve the MBR and drop the stray GUID partition table identifier entirely:

sudo fixparts /dev/sda

More information here: http://www.rodsbooks.com/fixparts/

  • Finally, that did it. gdisk actually showed the MBR and GPT tables and all I had to do was delete the existing GPT. No need to fixparts/w which would have deleted my partitions, according to the prompt. Now just need to figure out why it didn't enter grub2 on boot and went straight to Windows =P Much appreciated, great quick response.
    – slowri0t
    Commented Nov 13, 2013 at 20:15
  • The situation described by yjwong is not a hybrid MBR; it's just stray GPT data on the disk. FixParts can fix the described problem without deleting existing MBR partitions; it will simply delete the stray GPT data, just as gdisk did. (gdisk is a little harder to use for this task.)
    – Rod Smith
    Commented Nov 14, 2013 at 16:49
  • @RodSmith Thanks for the clarification, updated my answer to reflect this. By the way, thanks for your tools and documentation. They are awesome and saved me countless times. Commented Nov 14, 2013 at 17:30
  • @slowri0t Glad you got it fixed! Commented Nov 14, 2013 at 17:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .