Unity won't run on my new Ubuntu 11.04 install (with a Nvidia GeForce GO 7400). Ubuntu classic desktop works though, I tried all different drivers provided in the repositories.

Doing SystemAdministrationAdditional Drivers gives me a warning :

This driver is activated but not currently in use.

I even tried the Nvidia driver from the official Homepage.

After some googling, I found the tool /usr/lib/nux/unity_support_test -p which tells me that my card is blacklisted. The other tests show a green yes.

Is this a bug? Or is my card too old which would be pretty surprising for me :P ?


4 Answers 4


We blacklisted Geforce Go 7300/7400 because of some freezes at startup with the "nvidia-current" driver.

It seems that unity 3D can run with the "nvidia 173" driver with those card. However, you will get some slowness, you are warned!

So, to workaround the detection at startup, you can:

  1. sudo nano /etc/environment
  3. Save the file with Ctrl+X
  4. reboot

Ensure you are choosing the "ubuntu" session in gdm (default). This will bypass the detection and try to start unity 3D.

  • 1
    that work around worked for me. i adjusted the file manually not with nano and it worked! i have unity now. thanks, hope the new drivers will work soon with the go 7300
    – suli8
    Apr 28, 2011 at 22:34

Just for reference, here's the bug report about this issue.

Another option you've got is to use the experimental 3D support with the open source nouveau driver. It's probably slower than the proprietary nvidia driver, but it's been working great for me.

In order to install it, just open the application dash with the Super+A key combination, start typing 'jockey' without the quotes and select the Additional Drivers result. This will start the jockey-gtk application, where you can select to install the nouveau driver with experimental 3D support.

You'll still need to force unity to run by adding UNITY_FORCE_START=1 to /etc/environment, as explained in the other answer

  • 1
    FWIW, you may need to edit /etc/modprobe.d/nvidia-graphics-drivers.conf and remove nouveau from the blacklist to see it in the "Additional Drivers" screen.
    – kctang
    May 17, 2011 at 11:54

You can actually try unity-2D:

  • Yes. That would be an option. Thanks. But is there no possibility to use the normal one? I don't understand how a desktop needs so many grafical features. I can play 3D games with my card XD
    – Dominik
    Apr 28, 2011 at 20:26

I have a NVIDIA GeForece FX 5700LE and trying to install Ubuntu 14.04 I found this question when I discovered that unity did not support my video card.

While my answer does not answer the question, it might help other in the same situation who come across this question.

In my case didrocks' solution did not work. I had to punt unity and go with gnome.

  1. @terminal: sudo apt-get gnome-session-flashback
  2. Reboot
  3. @login screen: click the icon to the upper right of name and select: GNOME Flashback (Metacity).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .