0

I started updating the distro from 13.04 to 13.10. Then I got my hands on a Radeon HD 2600.

I installed the RV630 compatible Catalystdriver from the official webpage.

Then xserver crashed everytime I opened a browser or vlc fx.

I took notice that there was no driver listed in configuration underneath.

michael@statubtunu:~$ lshw -c video
WARNING: you should run this program as super-user.
*-display UNCLAIMED     
description: VGA compatible controller
product: RV630 PRO [Radeon HD 2600 PRO]
      vendor: Advanced Micro Devices, Inc. [AMD/ATI]
      physical id: 0
      bus info: pci@0000:01:00.0
      version: 00
      width: 64 bits
      clock: 33MHz
      capabilities: vga_controller bus_master cap_list
      configuration: latency=0
      resources: memory:d0000000-dfffffff memory:e0500000-e050ffff ioport:1000(size=256) memory:e0000000-e001ffff

i installed additional drivers from jockey and the ubuntu softwarecenter ati-driver. though that only made it to crash xserver completely and when i type:

michael@statubtunu:~$ sudo startx


X.Org X Server 1.14.3
Release Date: 2013-09-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-37-generic i686 Ubuntu
Current Operating System: Linux statubtunu 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 17:26:33 UTC 2013 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.0-13-generic root=UUID=8fb2e395-0ea2-4f45-ac66-225696b7ce2c ro quiet splash vt.handoff=7
Build Date: 15 October 2013  09:23:29AM
xorg-server 2:1.14.3-3ubuntu2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.30.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 12 18:50:02 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension SELinux
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
ERROR: could not insert 'fglrx': No such device
(II) [KMS] drm report modesetting isn't supported.
(EE) 
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0xb77780b9]
(EE) 1: /usr/bin/X (0xb75d8000+0x1a3e24) [0xb777be24]
(EE) 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb75b540c]
(EE) 3: /usr/bin/X (xf86findOption+0x2a) [0xb7681daa]
(EE) 4: /usr/bin/X (xf86findOptionValue+0x23) [0xb7681f43]
(EE) 5: /usr/bin/X (0xb75d8000+0x7ebfd) [0xb7656bfd]
(EE) 6: /usr/bin/X (xf86ProcessOptions+0x37) [0xb7657507]
(EE) 7: /usr/lib/xorg/modules/libvbe.so (vbeDoEDID+0xe7) [0xb5eb8647]
(EE) 8: /usr/lib/xorg/modules/drivers/vesa_drv.so (0xb5ee7000+0x287c) [0xb5ee987c]
(EE) 9: /usr/bin/X (InitOutput+0xb23) [0xb7659c33]
(EE) 10: /usr/bin/X (0xb75d8000+0x2a30b) [0xb760230b]
(EE) 11: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xf5) [0xb71ba905]
(EE) 12: /usr/bin/X (0xb75d8000+0x2a908) [0xb7602908]
(EE) 
(EE) Segmentation fault at address 0x5
(EE) 
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
     at 
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.

This is what comes, but no GUI.

Is there any way to deal with this?

3

If I'm not wrong, the kernel used by Ubuntu 13.10 (3.11) no longer supports the legacy AMD proprietary Catalyst drivers. Your only choice now is to use the Open Source radeon driver that comes with Ubuntu. It should already offer decent performance (~80%) and power consumption as compared to the Catalyst driver by now.

To fix the issue, you need to uninstall the Catalyst driver:

sudo apt-get purge fglrx

If for some reason you really need the proprietary driver, this link may help: http://ubuntuforums.org/showthread.php?t=2181190&p=12823425#post12823425

2
  • You are right, v. 13.04 supported the x86 drivers, and it might not be the only argument (wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories) as of xorg1.14 no longer are in use to catalysts. Thank you for your help! – MichaelR Nov 16 '13 at 0:39
  • @MichaelCephalus You're welcome. I'm also kind of stuck in the same boat, but decided to go with the Open Source driver (which can actually already run stuff like Metro Last Light). If my answer helped, please do accept the answer. Thank you! – yjwong Nov 16 '13 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.