Right, I've spent upwards of 8 hours on this and I just can't solve it!

Firstly, I couldn't log in to phpmyadmin with every combination of possible default password and usernames until I had to go into config.inc.php and change a setting (I think autopassword?) to "False". Then I logged in and nothing worked properly, so I had to import a file, so I did and it kind of worked, but when I went to access my tables after it gave an error and refused to work. So I tried reinstalling phpmyadmin in various ways, but now I can't log in at all, no combination of username and password or no password will work!

I've tried that many different things I can't even remember what did what now, and I'm pretty sure I need to remove the entire thing and start fresh but it doesn't seem to work since when it creates the login in the new install, the details I entered (or ven didn't enter) do not work.

Can anyone please point me in the right direction?

(Also, no matter what order of things I do the settings prompt will always give me an error, various different kinds.)


When I get close to what might seem like a solution I will always get this message:

sambo@sambo-To-be-filled-by-O-E-M:~$ sudo mysqld --skip-grant-tables &
[2] 10387
sambo@sambo-To-be-filled-by-O-E-M:~$ 131112 17:25:57 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
  • Is the username and password you are trying the same as your mysql username and pass? – Dan Nov 12 '13 at 14:33
  • I don't know anymore, I've tried that many username and password combos and reconfigures I don't know which is the definite username and password anymore, but ANYTHING I do now will not get past ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) No matter what I try. – Sambo Nov 12 '13 at 16:07
  • Try to purge everything related to this (something like sudo apt-get autoremove --purge phpmyadmin mysql-server mysql-client apache2 php5 libapache2-mod-php5 php5-mysql, then check if everything was really removed). Then start over and install the packages mysql-server and phpmyadmin (that should install everything that is needed, and you should be asked to input a password for the first mysql user several times). Tried this now in Ubuntu 13.10 using Synaptic and I didn't have a problem. – user180409 Nov 12 '13 at 19:24

If you're willing to, and nothing was already working, just try re installing everything including Apache2, MySQL, and PHPMyAdmin using the commands

sudo apt-get remove apache2 phpmyadmin mysql

Then, just reinstall it (making sure to update things really quick before you do so)

sudo apt-get update && sudo apt-get install apache2 phpmyadmin mysql
| improve this answer | |

If phpmyadmin fails, you could give Adminer a try. Everything is included in one php file and the installation is a lot easier. But you have all the necessary features and a nice interface.


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.