10

Everything was working great about 3 hours ago on my maverick machine.Then an issue cropped up.

I ran the command chown -R someuser:somegroup .*, and before I had noticed the ., I hit Enter, and this mistake made that half my system was owned by someuser before I could stop it.

I managed to get everything back to root (namely, /sbin, /etc, /lib, and some stuff under /usr). I apt-get --reinstall installed a pile of packages, including ALSA.

Unfortunately, ALSA doesn't work for non-root users. That is, sudo aplay /usr/share/sounds/alsa/Noise.wav works fine, but as an unprivileged user, it spits out

"cannot find card '0'"`

Although adding my users to the audio group might work, I'd read many places that this is no longer the solution to these problems.

So that leaves me with the question - where should I look to find my hosed permissions?

0

1 Answer 1

11

Okay, I got lucky, and noticed that the ACLs weren't set in /dev/snd

Just in case anyone happens upon a similar problem, I managed to fix it:

sudo setfacl -m u:$USER:rw /dev/snd/*

If anyone sees a problem with this, please respond in the comments, I want to make sure I did this right...

5
  • 2
    As pointed out in a (now deleted) answer this command may not work because the user is not in the 'audio' group. Adding the user to the 'audio' group works around this.
    – Seth
    Dec 27, 2014 at 23:39
  • I had to add my user to the 'audio' group, to get it work. Thank you, Seth !
    – rundekugel
    Jun 19, 2017 at 22:24
  • After long search this was the solution also for me. Now looking on how to get ACL settings on /dev permanent or how to disable ACL completely. Jul 21, 2019 at 13:59
  • Thank you very much. Just recently installed 20.04 and I had a similar problem. This solution solves the issue. Regards Jun 11, 2020 at 1:22
  • 1
    Unfortunately, I've tried this and it doesn't work in my case. My user is already added to the audio group, so that's not it. The interesting part is that I do get a sound for a couple of seconds (say if I watch a video) and then it starts to slowly turn down until it's fully muted. Dec 1, 2020 at 6:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.