I upgraded from 10.10 to 11.04 today, so I'm using Unity now, and Dropbox has disappeared from the indicator area. It still works, but it's hard to use now.

I've already tried removing it and reinstalling from the site. I noticed that this readds the dropbox repository to the APT sources (the upgrade disabled it), but it's a maverick source.

How can I get it back?

  • I have it running fine on a clean 11.04 install and I confirm it does still show a maverick repo installed, so you can at least rule that out as part of the problem.
    – rymo
    Apr 28 '11 at 15:41

have you checked if it's actually running? possibly you run a non-current release of dropbox, and just the indicator has vanished. dropbox only recently added indicator-applet compatibility, which is needed for natty.

upgrade dropbox by running

dropbox stop
rm -r ~/.dropbox-dist
dropbox start -i

edit: not that bug after all, thx jorge. Seems to be fixed with a new dropbox version, though: http://forums.dropbox.com/topic.php?id=37361&replies=20#post-315358

  • Yes it's running. I'm also sure there was an indicator in 10.10, not a system tray icon. I have Dropbox 1.0.10 Apr 28 '11 at 15:49
  • have you upgraded db yet? current general release version is 1.1.28, see dropbox.com/install
    – Christoph
    Apr 28 '11 at 15:53
  • I assumed that having the Dropbox repo in there would upgrade it, but apparently not. Looks like only nautilus integration is in there, or something. Not very user friendly... Apr 28 '11 at 15:57
  • the repo is just for the nautilus integration component. db core updates are pulled directly from their server if you do what i posted above. (and per auto-update at the discretion of the db team, this should also work on linux. they are mega-cautious with that, though)
    – Christoph
    Apr 28 '11 at 15:59
  • Yeah I just read that on their site. Anyway, I have 1.1.28 now. Apr 28 '11 at 16:05

Dropbox themselves have just released today the their latest version with App Indicator support.

It should update automatically or you can get it here.

  • In the meantime I reenabled the system tray via the fix also mentioned in that article, and Dropbox showed up there. Then I followed these instructions and it stopped working. The icon is still there, but clicking (with any button) does nothing. Apr 28 '11 at 15:56
  • I'm very suspicious with that "system tray" fix - as you have found, if I enable the system tray, drop box and several other application indicators dont work. I'm not using the "system tray" fix and drop-box works just fine.
    – fossfreedom
    Apr 28 '11 at 15:58
  • Well, I undid that fix, then logged out and in, and it works now...almost. I need to stop/start it first, every time I log in :( Apr 28 '11 at 16:04
  • there's no need to manually pull and unzip the packages. 1.1.28 is a general release, see my answer...
    – Christoph
    Apr 28 '11 at 16:04
  • That sounds like good news Christoph - I'll test this and amend my answer when I've confirmed. Bart van Heukelom - add this "dropbox start -i" to a new entry in your "Startup Applications"
    – fossfreedom
    Apr 28 '11 at 16:09

I did:

dropbox stop
mv ~/.dropbox-dist ~/DROPBOX-DIST  # backup, just in case!  :-)
sudo mv /var/lib/.dropbox-dist /var/lib/DROPBOX-DIST  # idem
dropbox start -i

It recreated /var/lib/.dropbox-dist

I have no ~/.dropbox-dist now

Dropbox is working perfectly

Dropbox applet is working ok.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.