0

I have a Dell Dimdension 4550 I am trying to install Ubuntu 13.10 onto. I really would like tokick microsoft to the curb, but I can not figure this out for the life of me. The graphics card is a NVIDIA GeForce4 MX 420. When I do a fresh install it works, but the system is unbearingly slow. When i check the system monitor the CPu is pegging out t 95%-100% usage. When I check the hardwade it says there is a problem with compiz. I tried multiple sugeestion to get the latest drivers, but when I install and reboot I get a black screen and nothing haapens. Any suggestions I truly would appreciate it.
thanks in advance

  • This trick is useful also in Lubuntu 14.4 and 13.10. Video Rendering using accelerated Nouveau drivers is abysmal on this system. I am sure the system is not properly using acceleration because I can hear the CPU fan blowind full speed just surfing any news website. Eventually It's much better to disable acceleration. Once acceleration is disabled the fan noise went down. Video rendering while browsing websites and while hovering files on PCManFM was much better (I eventually could see the icons and the name of files on PCManFM or Synaptic). My system is a Dell Dimension 4550 and the video is – user273088 Apr 23 '14 at 14:50
  • @user273088, and the video is GeForce4 MX 420? – jarno Dec 29 '15 at 12:41
2

I had trouble with the same type of system. What finally got me working was to disable the acceleration support in the nouveau driver. Via sudo, I edited /etc/defaults/grub so that:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Became:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.noaccel=1"

And then:

sudo update-grub

I restarted the machine, and the graphics issues were resolved. Admittedly, I'm disabling the acceleration support - but I'd rather have slow correct graphics than fast incorrect ones.

In my case, the issue was that I'd have color corruption (in some cases, full white out) on icons and in terminals. At first I tried disabling the display compositing (Settings Manager -> Window Manager Tweaks -> Compositor). That helped a bit, but I still saw numerous issues.

I attempted to figure a way to install the nvidia driver, but my understanding is that I need the 96.43 one. The .run file from nvidia doesn't work for newer kernels, and I gave up on that approach after a while. I attempted to find a repository with a recent 96.43 package, but had no luck. My guess is that folks have better things to do with their time than update packages for drivers that support cards that are roughly a decade old...

Along the way, though, I had noticed that rdesktop had no display problems. I figured that the code there likely wasn't calling for acceleration, so I figured it was worth trying to disable it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.