8

I'm a "newbie" to Ubuntu, but I've been wrestling with this problem for several hours and don't seem to be able to solve it: When I set the time in Windows (Indianapolis, Eastern U.S. time zone) and then re-boot to Ubuntu, the computer time goes to Hawaiian time. When the time is set in Ubuntu, and the computer is rebooted to Windows the time is advanced by 5 hours.

I've set the time in the BIOS, and it seems to make no difference. I've tried setting the time from "automatic" to "manual", all with the same result. Not a big problem, but it shows some underlying glitch. Could anyone explain?

0
6

It is because Linux stores time as UTC and windows as Local.

You can make Linux use local time or Windows use UTC.

To make Linux use local time edit /etc/default/rcS and change UTC=yes to UTC=no

To make Windows use UTC, create a new file named UTC.reg with the following content:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
"RealTimeIsUniversal"=dword:00000001

and open it with regedit in windows.

1
  • 1
    Although you should probably avoid UTC on windows. It does some weird stuff. I'd post some links but i can't remember where i saw all those issues windows had with utc. Nov 11 '13 at 17:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.