0

How do I install/enable KVM on Ubuntu 13.10 server?

I executed the following steps

egrep -c ‘(svm|vmx)’ /proc/cpuinfo
sudo apt-get install qemu-kvm libvirt-bin bridge-utils virt-manager
sudo adduser test1 libvirtd

Did not get any installation issue. But when I try to execute

sudo virsh -c qemu:///system list

I'm getting the following error

error: failed to connect to the hypervisor 
error: Cannot recv data: Connection reset by peer

I repeated the above installation process on different machine, which is also having Ubuntu 13.10 server. On this machine I'm getting the following error

error: failed to connect to the hypervisor
error: Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory

Need help on these issues.

1
  • What is the output of egrep -c ‘(svm|vmx)’ /proc/cpuinfo and kvm-ok?
    – jobin
    Commented Jun 24, 2014 at 4:09

1 Answer 1

1

For /var/run/libvirt/libvirt-sock:No such file or directory error:

check if root its in the default group (libvirtd), watch the logs (/var/log/messages), check:

virsh 'net-list '

and see if its really exist a default option. this problem can be also that libvirtd its not running, if its that so try:

service libvirtd restart
/etc/init.d/libvirt restart

or check if its in the rc.d files, start it up when the machine boots.http://wiki.libvirt.org/page/The_daemon_cannot_be_started

1
  • on my machine the daemon is not present ... I have installed the following package: qemu-kvm libvirt-bin bridge-utils virt-manager Commented Mar 11, 2015 at 10:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .