I'm going to install server without USB disk or CDROM via PXE with Ubuntu.

Currently, I have prepared a server with CentOS complete with DHCP, and TFTP server. I have successfully installed CentOS via network. But I'm stuck with Ubuntu.

I have copied linux file under netboot and initrd to tftpboot. Boot from it, but unfortunately when the system is up, it failed to auto-configure my eth0, I have no idea since it was fine with CentOS. Also it was asking for mirror archive.

What I want is to install it from my local server (NFS). Does any one have the similar issue as me and how to solve it? Thank you.


I suppose that you have tried https://wiki.ubuntu.com/LiveCDNetboot.

I used to avoid drivers problems (no sure about your case) with different machines by boot using the whole LiveCD through network (tftp). (client should enough RAM to hold the whole CD image). 128MB above CD size will be good.

MemDisk is a netboot Kernel to load iso, img images.

My self I have tried booting 700MB image without any problem. Now, I use Ubuntu Mini ~13MB (So, it will work with low RAM clients).

LABEL mini_ubutnu
    MENU LABEL Mini-Ubuntu
    KERNEL memdisk
    APPEND initrd=ubuntu_mini.iso

I extracted an Alternative CD to be served through an Apache web server as a Package Repository. (I didn't modify image to use local repository, each time I fill manually the URL)

You can even flash Bios through netboot.

LABEL slitaz
    MENU LABEL ^Slitaz.iso
    KERNEL memdisk
    APPEND initrd=slitaz-cooking.iso

LABEL freedos_std
    KERNEL memdisk
    APPEND initrd=FDSTD.144

LABEL bios_flash
    MENU LABEL Bios Flash
    KERNEL memdisk
    APPEND initrd=bios_flash.img
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.