0

I just installed Ubuntu 13, and while trying to set up Eclipse on my computer I ran into a weird issue- the toolbar in Eclipse refuses to function correctly if I do not run the Eclipse executable as root.

Here are screenshots of what I am talking about. The first screenshot is of Eclipse when I do not run it as root. The toolbar (i.e. the bar with 'file,'edit,' 'refactor' and so on) is merged with the system toolbar. I could bear with this except for the fact that none of the icons are clickable- that is, clicking 'file' gives no dropdownenter image description here

The next screenshot is of the Eclipse when run as root- the toolbar is slightly offset from system toolbar, it has the layout that we all know and love, and is perfectly functional.enter image description here

For the life of me I can't figure out why this is happening. I've tried redownloading Eclipse, running it under both open and sun JDK's, and every situation the same problem arises. As you can imagine it's rather annoying to have to navigate to the executable, open a terminal, and run it with sudo privilieges whenever I want to open Eclipse (which is a lot), so I'm looking for solutions to this annoyance.

I'm, again, running Ubuntu 13 (never had this problem with 12), using the Sun JDK. The owner of the executable is me.

If it matters before actually opening Eclipse and seeing the problems I used the instructions from the top answer of this askubuntu thread to make a desktop icon for Eclipse.

Anyways, hoping to see your answers soon!

0

Same issue - https://stackoverflow.com/q/19452390/

Short answer is that it's a known bug in Ubuntu 13.x, and a workaround would be to set the environment variable UBUNTU_MENUPROXY=0, either in the terminal or in the desktop shortcut. Here's a sample:

[Desktop Entry]
Version=4.3.1
Name=Eclipse
Comment=Eclipse IDE
Exec=env UBUNTU_MENUPROXY=0 /path_to_eclipse/eclipse
Icon=/path_to_eclipse/icon.png
Terminal=false
Type=Application
Categories=Utility;Application;IDE

Credits to the contributors on the question URL above for the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.