48

This is incredibly weird. I don't see "preferences" in any of my gedit menus. I'm running Version 3.8.3. All I want to do is show line numbers, but I can't do that without preferences.

Where the heck are they hiding?

note: I did remove indicator-appmenus because I dislike having the menus detached from the window.

2015 Update: somehow this is being flagged as a dupe of Enable line numbers in gedit which is a little confusing. The solution is the same but the questions are different.

  • Does your gEdit have a gear icon in the main window toolbar area? – dobey Nov 10 '13 at 17:14
  • 1
    @dobey no, it doesn't. – Amanda Nov 10 '13 at 17:21
  • Eeesh. @vasa1 It does. Editing my Q – Amanda Nov 10 '13 at 17:33
  • 4
    iwould ck here as the issue was no preference menu option askubuntu.com/questions/364117/enable-line-numbers-in-gedit/… – doug Nov 10 '13 at 18:22
  • 1
    What did work was explicitly setting line numbers w/ ` gsettings set org.gnome.gedit.preferences.editor display-line-numbers true ` – Amanda Nov 10 '13 at 23:28

10 Answers 10

30

I'm not sure how to get preferences back in your menus, but you can use gsettings to display line numbers. Enter this command into the terminal:

gsettings set org.gnome.gedit.preferences.editor display-line-numbers true

In case you need to change other settings for gedit, you can use this command to find quite a few that are available: (thanks to this answer)

gsettings list-recursively | grep -i gedit
| improve this answer | |
  • 14
    cannot believe why gedit became so hard to use these days.... – BufBills May 16 '14 at 3:28
  • 2
    +1 because this answer is valid for Gedit in GNOME 3.12 and probably for newer releases also. Gedit in newer releases doesn't seem to have the preferences dialog as described here. – clearkimura Jan 12 '16 at 18:03
47
+100

if you are using GNOME 3, you can access the preferences via the top menu.

you should have "activities" on the top left corner of your screen. on the right side of activities, you will have gedit. click on it, and you should see the preferences.

| improve this answer | |
  • I do see preferences, but clicking it doesn't bring up anything. – Irfan Jan 29 '14 at 12:14
  • 1
    @Power-Inside if you've got a top menu but the "preferences" menu item isn't doing anything, you probably want to start a new question. – Amanda Jan 29 '14 at 13:57
  • 2
    ew! yet another reason for me not to return to gnome. why move preferences to a mac style location?? absurd – jozxyqk Feb 28 '15 at 6:22
  • It helps me. Thank you! I found a lot of tips for accessing through "edit" menu, however I couldn't find on my Ubuntu GNOME 16.04. I couldn't imagine that it moved onto a global menu. – hata Aug 5 '16 at 15:17
  • 2
    launching it with sudo the preferences are in the standard three-bar, and not the top bar, and preferences are locked (gedit 3.30 under Arch) – user1708042 Sep 27 '18 at 21:08
19
+50

To get the preferences entry back to the edit menu perform the following command in a terminal:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides '@a{sv} {"Gtk/ShellShowsAppMenu": <int32 0>}'

The problem results from Gnome3 putting the preferences menu entry to the top menu.

| improve this answer | |
  • 1
    Thank you, this was the only solution that worked for me (using CentOS but solution is the same). Can't believe this is hidden by default!! – crobicha May 25 '16 at 15:10
15

Just type Alt+E, then again E when you are in gedit. A new window called "gedit Preferences" should appear.

gedit preferences

| improve this answer | |
  • 3
    No dice, I'm afraid. – Amanda Nov 10 '13 at 17:21
  • @Amanda I am using gedit 3.8.3 in Ubuntu 13.10 and this is how I open preferences in gedit. I made you also a picture to prove you. – Radu Rădeanu Nov 10 '13 at 17:31
  • 2
    I believe you, but my edit menu ends at "Insert Date and Time" – Amanda Nov 10 '13 at 22:42
  • @Amanda You can also use gsettings to change gedit's settings. – OSE Nov 10 '13 at 23:18
  • This works for me: gsettings set org.gnome.gedit.preferences.editor display-line-numbers true – OSE Nov 10 '13 at 23:20
4

Faced similar problem...got the preference option in the activities bar in the left hand corner..I am using gedit v3.22.1

gedit preference setting

enter image description here

| improve this answer | |
3

You may need to use tweak tool to turn off temporarily some of the common extensions normal people now use to make gnome 3 usable on a desktop. For me, I had to turn off the taskbar and applications menu extensions. Then one can use the method described by Buğra Koç above.

This means the easy switching on and off of line numbers and word wrap in gedit is gone.

If you don't need text highlighting Leafpad is a good replacement for gedit. It looks like the old gedit:

sudo apt-get install leafpad
| improve this answer | |
3

In my desktop, I found it here: enter image description here

| improve this answer | |
  • That is the best answer for me! No need to use cli or disable ui extensions. Just right-click gedit icon in panel - and you got it! You just saved my day, thanks a lot! – thybzi May 20 at 9:45
0

The preferences are under edit at the bottom of the list. enter image description here

Try to get the menu-bar back, or if that fails remove it entirely and install a fresh new instance of gedit, mine is 3.10.4, so yours is a bit old!

| improve this answer | |
0

I know this is an old thread, but I just ran into the same problem. In the end, I figured out that it was because I was still logged in as the superuser. Once I logged out of the terminal and reopened the terminal, everything went back to normal.

Just thought I'd throw that out there in case anyone else hits the same problem.

If you're seeing a # instead of a $ at your command line, this is likely why you can't see your defaults.

| improve this answer | |
  • Although this is true, it doesn't explain how to access preferences when using gedit with super user sudo powers. – WinEunuuchs2Unix Mar 26 '17 at 19:15
0

You can access the preference settings of any app by installing dconf-editor:

Debian derivatives:

sudo apt install dconf-editor  

Redhat derivatives:

sudo yum install dconf-editor # for Fedora replace yum with dnf

Then open dconf-editor

dconf-editor &>/dev/null &  

Click the search icon and type gedit or follow this path: org/gnome/gedit/preference/editor/display-line-number

Turn off the default value and make the custom value true

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.