6

I recently bought a Dell Inspiron 15R SE with Windows 8 (64 bit) pre-installed (UEFI supported). I want to install Ubuntu in dual boot with Windows 8. I tried to follow all these instruction and these instructions too.

  • So, I set Secure Boot to "off" into BIOS and I disable Fast Startup as described here.

  • I created a bootable USB key for Ubuntu (Ubuntu 13.10 64bits international Edition) with Unetbootin.

The problem is I am unable to boot from the USB key. The computer tries to boot into infinite loop (when the USB key is plugged in, the computer starts and the Dell logo appears. The little blue progress bar is growing normally. When it is complete, the computer restarts and does the same thing). I also tried to boot from USB with "Legacy Boot" option instead of UEFI. In this case, the computer freezes at Dell logo.

Of course, I tried to boot from my USB key on an other computer having normal BIOS and it works perfectly.

Have you ideas about what I need to do to be able to boot from USB?


UPDATE:

What I have tried:

  • With UEFI Boot mode:

    • Secure option: Disabled
    • "Intel speed step": Disabled
    • Windows 8 FastStartup: Disabled

    Using bootable USB key for Ubuntu (Ubuntu 13.10 64bits international Edition) with either Unetbootin or Linux dd utility.

    Result : Unable to boot from the USB key. The computer tries to boot into infinite loop.

    • With "Legacy Boot" option:

    Using bootable USB key for Ubuntu (Ubuntu 13.10 64bits international Edition) with either Unetbootin or Linux dd utility.

    Result: Unable to boot from the USB key. The computer freezes at Dell logo. If I press F12, the computer freezes instantaneously.

  • put in legacy mode and make sure that you boot from a usb device. – Avinash Raj Nov 10 '13 at 12:58
  • Press F12 in legacy mode with my bootable USB key is freezing my computer, so I put a non-bootable USB, press F12, and change boot order to set USB first. After restart with my bootable USB, the computer freezes at Dell logo. – Adele Nov 10 '13 at 15:04
  • What video mode does system boot with? If nVidia you need nomodeset, or if Intel you need settings for that. askubuntu.com/questions/162075/… – oldfred Nov 10 '13 at 21:35
  • AMD Radeon in my case. But I am not able to boot from USB, so I don't see neither GRUB menu nor purple or black screen. I think the computer freezes before that. Here is what I see when the computer freezes – Adele Nov 10 '13 at 22:38
  • Perhaps it's a bug in Dell's EFI implementation. Try updating it. – John Scott Sep 13 '14 at 20:33
2

In Windows 8, open the settings charms by pressing Windows+I keys. At the bottom, you’ll see the option of Change PC settings. Click on it. Then you need to go to General PC settings and select Advanced startup and then click on Restart now. It actually won’t restart right after it, but it will provide some option that you will see on next boot. You should to choose Use a device. In Use a device menu select EFI USB Device and your computer will start to boot from the flash-drive.

  • This is perfect. Once Windows is booted, this method works. – Mvorisek Feb 20 '18 at 19:07
2

On my ThinkPad Ubuntu 14.04 went into the infinite loop, Ubuntu 15.04 did not. Furthermore:

  • proper shutdown in Windows
  • UEFI on (important)
  • CSM yes
  • SecureBoot off

After installing Ubuntu, only boot to Windows was possible: boot Ubuntu from live and install + run boot-repair. This way grub is the first thing that comes up. Windows boot loader can be skipped with EasyBCD and in Linux grub-customizer to clean up the grub menu.

2

I had the same problem with my new Samsung Ativ 9. The following changes to BIOS helped: (For Samsung F2 entered BIOS)

  • Advanced: Fast boot mode to disabled
  • Boot: Secure Boot to Disabled
  • Boot: OS Mode Select left at UEFI OS (To allow Windows alongside)
  • Boot: Boot device priority -> set USB HDD at top

I also had to turn off fast boot option under control panel under Windows 8

  • Thanks for sharing, I tried this into BIOS : -Advanced: Disable "Intel speed step" -Secure Boot Disabled -Boot mode UEFI I can't set Boot device priority in UEFI mode. But I think the infinite loop I have means it tries to boot from USB. – Adele Nov 10 '13 at 15:14
0

See my page on installing Linux on EFI systems. In particular, you may be having problems because you used unetbootin -- the Ubuntu installer should work fine if copied to a USB flash drive via the Linux dd command or equivalent tools in Windows. More complex programs, like unetbootin, were designed with BIOS-mode booting in mind. Furthermore, EFIs vary greatly, making it impossible for developers of such tools to test on a wide enough variety of systems. Such tools can therefore sometimes create USB flash drives that are unbootable in EFI mode.

I do not recommend installing in BIOS/CSM/legacy mode except as a last resort. Doing so will require you to install an EFI-mode boot loader after the fact, which is extra work that can itself cause confusion and complications. (I can't count the number of questions I've seen from people who need help with this.) That said, on rare occasion it is necessary to install in BIOS/CSM/legacy mode and deal with the EFI boot loader installation issues, or even re-install Windows in BIOS/CSM/legacy mode to work around particularly buggy EFIs.

  • Thank you, your page helped me to learn more about UEFI. I just tried to prepare my USB key using Linux dd utility instead of Unetbootin but I have the same issues than earlier. I updated my post with handlings I tried. By reading your page I am worried about the complexity brought by this new firmware technology to set up a dual-boot on a computer. It's frustrating because this makes it difficult to install alternatives to Windows. – Adele Nov 10 '13 at 21:39
  • Could you clarify what you mean by "infinite loop?" Do you mean that the computer reboots when it tries to launch Linux? If so, that sounds like a driver problem. You might try another distribution (they often differ in their drivers, particularly for brand-new devices). It could also be that your computer is just too new to be supported by Linux, in which case returning it for another model with a different chipset might be the best option. – Rod Smith Nov 10 '13 at 22:40
  • In fact, when the USB key is plugged in, the computer starts and the Dell logo appears. The little blue progressbar is growing normally. When it is complete, the computer restarts and does the same thing. Here is a screenshot: i.stack.imgur.com/MA99H.png Thank you for your help. I'll try with another distribution as you suggest. – Adele Nov 10 '13 at 23:08
  • But unfortunately, my computer is new so maybe you're right... – Adele Nov 10 '13 at 23:25
  • Based on your description, something late in the boot process is causing an automatic reboot. There's a good chance that another distribution will fix this problem, but I can't make any promises. – Rod Smith Nov 11 '13 at 14:37
0

I had similar problem with Dell XPS 13 but with Ubuntu 12.04 64 bit. While trying to boot from USB it was going in an infinite loop as you mentioned. I had Legacy boot option as default. I then changed to UEFI mode which had only Network option in it. I then added a boot option and selected the USB file system location. Saved the BIOS and rebooted it worked fine!

0

On my version of UEFI on an ASUS VIVOPC The boot order cannot be changed from UEFI, and there fore I could not force a boot from my USB drive. However, after disabling secure boot, and enabling CSM legacy I pressed F8 upon start up and was able to select my USB drive and boot.

0

For a successful installation I needed an ESP partition as follows:

  1. Create the LiveUSB
    1. Fire gparted
    2. Delete all partitions if any
    3. Create a partition table
    4. Create a FAT32 partition
    5. Burn the ISO with gnome-disks
  2. Enter the BIOS
    1. Turn on UEFI mode
    2. Turn off
      • Secure Boot
      • Legacy ROMs
      • QuickBoot/FastBoot
      • Intel Smart Response Technology (SRT)
      • Fast Startup
    3. Add a UEFI boot option for the USB drive, choose grubx64.efi if asked for a file
  3. Boot the Ubuntu LiveUSB
  4. Fire gparted
    1. Select the hard disk
    2. Create a partition table
    3. This is the key part. Create a partition at the beginning of the disk with FAT32 format of at least 200 MB, 500 MB was my choice
    4. Set it with the flags boot and efi (I had to guess the last one, didn't find info anywhere)
    5. Create the remaining partitions as usual
  5. On the Ubuntu installer
    1. Choose to set hard disk partitions manually
    2. Set the HD first partition with the mounting point at /boot/efi
  6. And finally the usual rest of the process

That was on a Dell Inspiron 15-3552.

  • 2
    I recommend editing this answer to expand it with specific details about how to achieve this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Nov 8 '16 at 5:23
0

I had the same problem. I had Ubuntu and Windows, but I wanted to downgrade Ubuntu.

So, in the "Advanced" tag I disabled "Secure boot". In the "Boot" tag I disabled "Secure Boot" and elevated "USB hdd" to the top, while blocking (Shift+1) ! ubuntu, ! Windows Boot Manager and another hard disk. This way it finally worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.