I recently decided to use Virtualbox to run Ubuntu, but I get the message

this kernel required an X86-64 CPU, but only detected a i686 CPU

I've already enabled virtualization in BIOS, but that doesn't seem to work. Many other solutions suggest that I should download the 32-bit version, and not the 64-bit. I'm not sure about that though, since my computer clearly says "64-bit operating system" under systems. But I might just be mistaken.


Many other solutions suggest that I should download the 32-bit version, and not the 64-bit

That's the only solution actually. Download the 32-bits and proceed per usual.

Ubuntu is detecting that your processor architecture is 32-bit (anything that starts with i and ends in 86 is 32-bits: i386, i486, i586, i686). If you have a 64-bit processor them make sure you have a 64-bit kernel installed:

uname -a
Linux braiam-O_I 3.8.0-32-generic #47-Ubuntu SMP Tue Oct 1 22:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Those in bold indicates:

  1. Machine: x86_64 = 64-bits
  2. Processor: x86_64 = 64-bits
  3. Hardware platform: x86_64 = 64-bits

If some of them is 32-bits (or iX86) then you don't have an 64-bit system but 32-bits installed. You must also make sure that you installed the 64-bit version of Virtual Box.

  • Its all a settings issue. If the CPU supports it Virtual Box could even run 64-bit Ubuntu on a 32-bit host. – Takkat Nov 10 '13 at 8:23
  • @Takkat weird, because I didn't make anything in any VM to install 64 bit systems. Shouldn't VirtualBox just use the 64-bits version whatever happens? – Braiam Nov 10 '13 at 13:03
  • No, for obscure reasons it loads a different architecture (I had above error some time ago). – Takkat Nov 10 '13 at 16:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.