I've upgraded from Ubuntu 13.04 to Ubuntu 13.10, then ibus-avro for Bengali is not working. I've tried to reinstall ibus but no success. ibus-avro Icon is showing but not sure whats the problem.

It should be working like this... enter image description here

The icon on top is showing properly, but it's not working. May be there are some communication problem.

So currently after upgrade it's like this... enter image description here

As we can see the Bangla text is not appearing...

I've tried these steps...But no hope.

rm ~/.candidate-selections.json


sudo killall ibus-daemon
ibus-daemon -vx


/usr/bin/env gjs --include-path=/usr/share/ibus-avro /usr/share/ibus-avro/main-gjs.js

enter image description here


Just go to Terminal and type

sudo apt-get install ibus-avro-saucy

If you have not installed avro in Ubuntu 13.10 before then follow this

sudo add-apt-repository "deb http://download.opensuse.org/repositories/home:/sarimkhan/xUbuntu_13.04/ ./"


wget -q http://download.opensuse.org/repositories/home:/sarimkhan/xUbuntu_13.04/Release.key -O- | sudo apt-key add -


sudo apt-get update


sudo apt-get install ibus-avro-saucy

First of all, click the right mouse button on the icon and see if the input method can be selected. If that is the case, you are facing a problem with activation sequence.

enter image description here

In Ubuntu 13.10, the ibus activation key sequence has been changed to Super-Space. But the problem is, this works and again does not work. May be some final tweaking is still in the process. Please try Super-Space and see if that works for you.

Anyway, for my case, I changed the activation key sequence to the previously known Ctrl-Space. But due to some bug, this can not be changed readily. A patch is available for this one. To install the patch, please execute,

sudo add-apt-repository ppa:attente/1218322
sudo apt-get update
sudo apt-get upgrade

Then reboot your system. And change key sequence to Ctrl-Space (or whatever else is your favorite).

The above has worked for me, perfectly.

(You may want to see this question for a discussion on the bug.)

Please let me know if you still face any problem.

  • Thx but I didn't face this problem, because I've upgraded from 13.04 to 13.10. Without any changes I've changed the sequence to Ctrl-Space. – Faisal Nov 10 '13 at 18:25
  • @FaisalHaqSalafi I understand, but for my case, the input methods were not there. I also upgraded from 13.04 to 13.10. I had to add all the input methods fresh. – Masroor Nov 11 '13 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.