14

Since I upgraded from Ubuntu 10.10 to 11.04, my internet connection is as slow as hell. I have tested my other 10.10 machine and it is just as quick as the first one was.

What has happened? Why is the maximum download speed now 30kb/s instead of the 2.5mb/s I used to have?

  • 1
    We need more details. How are you connected to your ISP? What does ifconfig tell you? route? Is your cat /etc/resolv.conf (nameserver) ok? Only throughput slow, on every protocol, or are there delays; is ping slow too? – user unknown Apr 27 '11 at 23:13
  • How did you measure the bandwidth? Do you have speedtest results to compare from the two machines? – nik Apr 28 '11 at 14:52
  • My connection sometimes slow down and other times it speeds up. Sometimes it spends a lot "thinking", but the page freezes always reading... – Jorge Pinho May 3 '11 at 13:06
  • i think it is Chromium problem... Now i've tryed a while on firefox and WLAN was very quick... gmail without speed problems. Maybe the update that they have done today have some issues or bugs!? – Jorge Pinho May 3 '11 at 17:47
  • I've tryed this and it seems to me that my wlan0 connection works better now! I'm still testing, but you can try it too: type sudo iwconfig <return> note the name of wifi card (example eth1) type sudo iwconfig [name of card] power off <return> Now test speed. It appears 11.04 restricts power to Wifi card to save power at the cost of unusable internet! – Jorge Pinho May 4 '11 at 15:58
16

I've found out the problem; it's some sort of problem with my wifi driver (ath9k) which was resolved with a simple command:

sudo -s
echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf
| improve this answer | |
  • Report this for the relevant driver package on Launchpad. – Oxwivi May 6 '11 at 14:31
  • 1
    This didn't work for me, I had to upgrade my kernel to 2.6.39. It wasn't hard to do, and I describe how in askubuntu.com/questions/29950/…. – Adam Monsen Jun 20 '11 at 10:46
  • Thanks @Dante it seemed to work for me... What does that line mean anyway ? – user20656 Jun 26 '11 at 6:21
  • what this conf do under the cover ? – Jigar Joshi Oct 16 '11 at 10:50
  • This worked for me, just do a restart if it doesn't work for you right away. – tsusanka Feb 21 '12 at 10:43
0

I had the same issue, but only after upgrade to 11.10. Either way, neither echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf (s/9/5 if you're using ath5k) or disabling IPv6 (another solution floating around) helped.

What did help was changing the encryption on the network from WEP to WPA2 (inspired by a forum post I can't find at the moment on a related issue where encryption slowed down a wireless connection). It's still not as speedy as some of my other computers, but a whole lot better than it was.

| improve this answer | |
  • This did not work for me as I'm already using wpa2 – virtualxtc Dec 22 '13 at 9:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.