15

I have downloaded adobe reader 9.5.5 and installed it using gdebi.Now if I click on any pdf it is not starting.I tried "acroread" in terminal and it is showing me this error

/opt/Adobe/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libxml2.so.2: cannot open shared object file: No such file or directory

Then I have installed libxml2.But still it is showing the same above error. My system OS is ubuntu 13.10.

Is there any solution to my problem for using Adobe reader or any other alternative pdf reader other than foxit and default(evince) or okular by using which I can highlight any text in my pdf?

  • Here are meny Pdf Viewers. But in Evince, I can highlight text.(Not Images). Even Open URLs. – user224082 Nov 9 '13 at 15:30
  • 1
    I would recommend PDF-XChange-Viewer (under Wine) but perhaps you don't want it because it's like Foxit, just a little better. – Sadi Nov 9 '13 at 17:06
37

I resolved this issue on my 64 bits Ubuntu (13.10) using the following terminal command:

sudo apt-get install libxml2:i386 libstdc++6:i386

  • 1
    That solved mine too on ubuntu 14.04 LTS – Farzad YZ Jun 29 '16 at 16:14
  • 3
    This also solved it for me on Ubuntu 16.10 64bit – AndyGaskell Jan 23 '17 at 11:35
  • Worked for me on Linux Mint 18.3 Sylvia - Cinnamon – 43Tesseracts Feb 18 '18 at 8:34
  • Works for Ubuntu 17.10 64bit too! – HAVB Mar 14 '18 at 21:35
  • 1
    works for 18.04 64bit also – Leo Simon Jul 23 '18 at 16:01
2

Maybe this is an issue with symbolic link to the correct version.

Identify the library dependency of your program and locate the library like this (I don't have acroread, but should be same):

$ which evince
/usr/bin/evince
$ ldd /usr/bin/evince | grep libxml
libxml2.so.2 => /usr/lib/i386-linux-gnu/libxml2.so.2 (0xb7534000)
$ ls -l /usr/lib/i386-linux-gnu/libxml2.so*
lrwxrwxrwx 1 root root      16 Jul 16 20:48 /usr/lib/i386-linux-gnu/libxml2.so -> libxml2.so.2.7.8
lrwxrwxrwx 1 root root      16 Jul 16 20:48 /usr/lib/i386-linux-gnu/libxml2.so.2 -> libxml2.so.2.7.8
-rw-r--r-- 1 root root 1360484 Jul 16 20:48 /usr/lib/i386-linux-gnu/libxml2.so.2.7.8

If you do not have symlink named libxml2.so.2 pointing somewhere, create one:

$ sudo ln -s /usr/lib/i386-linux-gnu/libxml2.so.2.7.8 /usr/lib/i386-linux-gnu/libxml2.so.2

Change evince to acroread in your case. Hope this helps.

  • This ldd command does not list libxml anywhere in the output; for acroread I get the output " not a dynamic executable". Suggestions? – Steve Kroon Jul 2 '15 at 13:03
  • The acroread is a shell script, the binary can be found under /opt/Adobe/Reader9/intellinux/bin, which shows the list with ldd – André Schild Sep 4 '18 at 8:34
0

This also resolved it for me in Debian Buster using the following terminal command:

sudo apt-get install libxml2:i386 libstdc++6:i386
  • 2
    Please don't add "thanks" as answers. Invest some time in the site and you will gain sufficient privileges to upvote answers you like, which is the Ask Ubuntu way of saying thank you. – Martin Thornton Sep 22 '18 at 16:59
0

This link https://answers.launchpad.net/ubuntu/+source/acroread/+question/209800, post #23 and #24 can also help to solve this issue. I successfully applied both on Ubuntu 18.04, kernel 4.15.0-45-generic

$ sudo updatedb; locate libBIB
/opt/Adobe/Reader9/Reader/intellinux/lib/libBIB.so
/opt/Adobe/Reader9/Reader/intellinux/lib/libBIB.so.1.2
/opt/Adobe/Reader9/Reader/intellinux/lib/libBIBUtils.so
/opt/Adobe/Reader9/Reader/intellinux/lib/libBIBUtils.so.1.1

$ ldd /opt/Adobe/Reader9/Reader/intellinux/bin/acroread | grep not
libBIB.so => not found
libBIBUtils.so => not found
libACE.so => not found
libAGM.so => not found
libCoolType.so => not found
libAXE8SharedExpat.so => not found
libJP2K.so => not found
libAdobeXMP.so => not found
libicuuc.so.36 => not found
libResAccess.so => not found


$ sudo updatedb; locate libBIBUtils.so
/opt/Adobe/Reader9/Reader/intellinux/lib/libBIBUtils.so
/opt/Adobe/Reader9/Reader/intellinux/lib/libBIBUtils.so.1.1

$ cd /usr/lib
$ sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libBIB.so .
$ sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libBIB.so.1.2 .
$ sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libBIBUtils.so .
$ sudo ln -s /opt/Adobe/Reader9/Reader/intellinux/lib/libBIBUtils.so.1.1 .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.