4

Up until yesterday I was running Ubuntu 12.10 on my Dell Latitude E6530. Recently I played around with the nvidia settings, which caused my brightness control to stop working. However, I could fix it by adding Option "RegistryDwords" "EnableBrightnessControl=1" to /etc/X11/xorg.conf as advised in [1].

Now, last night I upgraded to Ubuntu 13.04 because I needed are newer kernel. After that, the brightness control once again stopped working. But this time, [1] doesn't help. I have also tried the methods in [2]:

  • acpi_backlight=vendor in /etc/default/grub
  • acpi_osi=Linux in /etc/default/grub
  • echo $SOME_VALUE | sudo tee /sys/class/backlight/dell_backlight/brightness

None of them are working, the brightness just doesn't change, but that's about all I could find for this problem. Any ideas on how I can get my brightness control back?


[1] https://askubuntu.com/a/270830

[2] https://askubuntu.com/a/289178/213036

  • Have you tried removing the Nvidia modules enterely? – Braiam Nov 11 '13 at 16:20
  • @Braiam Removed them altogether and tried different versions of nvidia drivers. Nothing. – Ingo Bürk Nov 12 '13 at 6:56
  • Just in case, did you remember to do sudo update-grub after modifying /etc/default/grub? If not, try both permutations with and without acpi_backlight=vendor. Also, with each permutations, try sequentially modifying other files at /sys/class/backlight/*/brightness. (This may be of interest: forum.kde.org/viewtopic.php?f=63&t=110984 ) – Sparhawk Nov 16 '13 at 1:16
  • I just tried again to make sure I used update-grub. I tried every permutation I could think of, but nothing. The only thing I notice is that if I change the brightness file and use the brightness key, I can see that Ubuntu's little popup responded to it. But the brightness itself just doesn't change. – Ingo Bürk Nov 16 '13 at 9:41
1

I have similar issue with my Sony Vaio. I tried all the methods that you have listed, but there was no effect.

However, in grub, editing lines as follows helped me. (Be sure to backup grub before any editing as a standard practice).

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=legacy" GRUB_CMDLINE_LINUX="acpi_backlight=legacy"

Note: We are using acpi_backlight=legacy instead of acpi_backlight=vendor here.

After saving, run command $ sudo update-grub and reboot your laptop.

Once I did that, the commands cat and tee started working for me to display and change brightness from Terminal.

  • This will give you maximum numeric value of brightness that your screen supports.

    $ cat /sys/class/backlight/dell_backlight/max_brightness
    
  • This will set your screen brightness value to your specified value, between 0 to max_brightness.

    $ echo <brightness_value> | sudo tee /sys/class/backlight/dell_backlight/brightness
    

For more information, refer to this backlight Wiki.

  • The max_brightness changed from 15 to 100, but setting brightness to any value still has no effect =/ – Ingo Bürk Nov 18 '13 at 6:51
  • @IngoBürk, I don't have any more suggestions as of now, since I am looking for a definite answer too. – Ninad Nov 18 '13 at 7:18
1

See my answer here.

The nomodeset kernel parameter may disable the brightness adjustment when used with acpi_backlight=vendor. Remove the former and add the latter.

0

I would suggest downgrading back to 12.10. 13.04 is in beta phase and still undergoing testing.

To answer your question, check your display and connection, the brightness may be low there. You may also have a bad graphics module in your computer (if this is a laptop, it may be the back light bulb). In either case, try hooking your computer up to a different display.

Hope I helped, If not, I am sure there is a simple fix we are overlooking. Just remember the 6 levels of Linux, in order to do one thing, you must fix six other things first. :)

  • Downgrading isn't an option, I am required to have at least 13.04 for other work-related reasons (which could maybe be fixed otherwise, but I tried that a lot before ugprading to 13.04). Yes, it is a laptop and I doubt it's a bad bulb since it is stuck on the brightest (not least brightest) setting. My laptop is, at work, always hooked up to a second display, but I've never been able to control the brightness of that display through my laptop brightness. I appreciate your time to answer, though. – Ingo Bürk Nov 14 '13 at 6:06
  • 1
    13.04 is not in beta phase! This was the second-last release. – Sparhawk Nov 16 '13 at 1:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.