2

I have been testing out connman, the alternative connection manager. While testing connman, I had to remove my network manager. I did an

apt-get purge network-manager*

Now, when I reinstalled the network manager and all its dependencies, including network-manager-gnome, I cannot see it on the panel however, the internet is connected through ethernet. I can access the internet on the browser and also connect vpnc through the cli. but the GUI does not recognize it. Any idea how to get the GUI recognize the eth0?

Adding screenshot for better understanding. enter image description here

  • Have you unplugged your Ethernet cable and rebooted, then configured your wireless? – wojox Apr 27 '11 at 17:48
  • its ethernet cable only. no wireless. as i said, i can get internet connection but its not displayed through the network-manager applet on the panel – Ubuntuser Apr 28 '11 at 9:00
2

Try to do as this answer suggests.

Long answer short, open /etc/network/interfaces in a text editor, sudo mode, and comment out the eth0 and whatever network interfaces you want to control on network-manager.

  • one thing i would like to add here is that, if i do this change, then i will not be able to get internet from the cli. doing ifconfig after this change will only show up the local adapter. – Ubuntuser May 2 '11 at 8:45
  • What do you mean? ifconfig shows all the network adapters regardless of it being commented out on the interfaces file. – Oxwivi May 2 '11 at 9:37
  • your suggestion worked out perfectly fine. Please ignore my previous comment. It has brought back my network-manager-gui detection. Also, ifconfig is now showing all the adapters and i can connect to my vpn as well!! A million thanks to you man!! – Ubuntuser May 2 '11 at 9:46
  • Glad it worked out for you. I faced this issue when experimenting with minimal installs. Many thanks to the original author of the solution I linked. – Oxwivi May 2 '11 at 9:49
  • I have the same issue with a ppp0 connection, I tried your suggestion but there was no ppp0 line to comment out. Is there anything else to be tried? – boywithaxe Jan 12 '12 at 20:30
0

I had the same issue, and this resolved it. If you have the package connman installed, try removing it, and rebooting.

  • connman gets remove when you reinstall network-manager – Ubuntuser Apr 28 '11 at 9:01
  • Blah... there goes my idea. Hope you are able to get it sorted out Ubuntuser. – Alan Apr 28 '11 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.