After an update on 13.10, my PC won't boot Ubuntu any longer.

It displays the infamous "Waiting for Network Configuration" message and then hangs.

I can go into recovery mode, and choose "Start networking" and then go to a root prompt, and that works fine. Ping works. /etc/network/interfaces contains just the two lines "auto lo" and "iface lo inet loopback".

I've double-checked that my network is working, the cable is working (it works on another PC) and the network card seems to indicate a connection.

Any suggestions on how to get my PC booted again? Right now I'm limited to a root shell prompt.

  • I've tried deleting everything in /var/run/dbus; there were two files left there. Rebooted, same issue. I tried removing the 120 second wait in /etc/init/failsafe.conf. Same result. At this stage my workstation is effectively dead. Any help would be appreciated. – user213017 Nov 9 '13 at 10:49
  • I assume you have already checked askubuntu.com/questions/63456/…? – kvz Nov 9 '13 at 20:57
  • Yes, I checked every issue I could find on this topic. It's something else... I'll try an older kernel tomorrow. – user213017 Nov 9 '13 at 23:46
  • I tried reverting to an older kernel, and emptying /etc/network/interfaces completely, changes nothing. There's a 2-minute wait "Waiting for network configuration..." and then it says, "Booting system without full network configuration" and that's it - doesn't boot. – user213017 Nov 10 '13 at 8:36
  • I've reinstalled Ubuntu, there seems no other fix for this. – user213017 Nov 10 '13 at 9:24

Did you try to do something like this?

In /etc/init/rc-sysinit.conf replace:

start on (filesystem and static-network-up) or failsafe-boot


start on (filesystem) or failsafe-boot

From Disable network configuration services during boot time

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.