2

On recent versions of KDE (4.10, 4.11 at least), the Conky window does not have a transparent background, despite settings in the .conkyrc file.

1

On my Kubuntu 13.10 installation, I got transparency working by doing 2 things:

  1. appropriate settings in .conkyrc (see below)
  2. Changing the compositing type from 'XRender' to 'OpenGL 3.1' in KDE System Settings > Desktop Effects > Advanced

The "magic" combination of options in my .conkyrc that work are:

own_window yes
own_window_title conky
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_argb_visual yes
own_window_argb_value 0
own_window_type normal

Note that as long as you use the argb options, you do NOT need to inlude own_window_transparent

if you include only own_window_argb_visual without own_window_argb_value, then own_window_transparent functions as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.