I've been looking quite a lot for this but couldn't find anything that worked.

I have an Intel Core I5-4430 based system with no extra graphics adapter (so it's using the on-board, integrated Intel Graphics HD that is part of the CPU), running Ubuntu 13.10.

When running BOINC World Community Grid it says "No usable GPUs". When running a bitcoin mining program it says "No OpenCL devices".

I searched the web, found two possible solutions - one was to use the Intel OpenCL driver for Xeon platforms, the other was to use the AMD driver. Tried both. I failed installing the Intel driver as there were too many prerequisites that I just didn't manage to install, and the AMD installation was quite fast to its size (it's 200MB, and took far less than a minute to install), but it didn't solve the problem.

Perhaps I'm looking in the wrong direction here, I'm not sure, but is there anyway I can utilize the advance features of my CPU for those distributed computation programs?


I tried installing the Intel driver again (and failed again), and this is the output of install.sh:

~/Downloads/intel_sdk_for_ocl_applications_xe_2013_r2_runtime_3.1.1.11385_x64$ ./install-cpu.sh 
In case of failure please consult README file
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
error: Failed dependencies:
    /bin/sh is needed by opencl-1.2-base-1:
    lsb-core-amd64 >= 4.0 is needed by opencl-1.2-base-1:
    libnuma.so.1()(64bit) is needed by opencl-1.2-base-1:
    libstdc++.so.6()(64bit) is needed by opencl-1.2-base-1:
    /usr/sbin/update-alternatives is needed by opencl-1.2-intel-cpu-1:
    /bin/sh is needed by opencl-1.2-intel-cpu-1:
    ld-linux-x86-64.so.2()(64bit) is needed by opencl-1.2-intel-cpu-1:
    ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) is needed by opencl-1.2-intel-cpu-1:
    lsb-core-amd64 >= 4.0 is needed by opencl-1.2-intel-cpu-1:
    libnuma.so.1()(64bit) is needed by opencl-1.2-intel-cpu-1:
    libstdc++.so.6()(64bit) is needed by opencl-1.2-intel-cpu-1:
    libstdc++.so.6(CXXABI_1.3.1)(64bit) is needed by opencl-1.2-intel-cpu-1:
    libstdc++.so.6(CXXABI_1.3)(64bit) is needed by opencl-1.2-intel-cpu-1:
    libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by opencl-1.2-intel-cpu-1:
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by opencl-1.2-intel-cpu-1:

I really don't understand why there are so many missing dependencies. I checked and actually have at least most of them (/bin/sh, for example. really?)

Also it seems there are many duplicates.

Regarding the second line, the one that talks about using Alien, well I did use alien to convert this package, including scripts, then tried installing using Ubuntu's package manager, but it also failed on missing dependencies.

Any ideas? What am I doing wrong?

Update 2

Following hbdgaf's link I followed the selected answer instructions and these are my outputs:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

$ ./capsbasic
Number of available platforms: 1
Platform names:
    [0] Experiment Intel Gen OCL Driver [Selected]
Number of devices available for each type:

*** Detailed information for each device ***

So apparently I need a different driver, but where do I find it? Seems the official drivers by Intel are not built for Linux.

  • Xeon is supported via the RPMs provided by Intel not the beignet project. Don't try and install the rpms... Just open them as archives and extract the contents where they should be. I tried converting them with alien including pre/post scripts and they were broken. – RobotHumans Mar 28 '14 at 10:47
  • Note: Since the beignet opencl driver didn't work you should remove it from your linker search path. If you added the right driver at this point, then it still might not work because of conflicting opencl shared objects. – RobotHumans Mar 29 '14 at 6:31

The issues is that Intel installer uses RPMs, while Ubuntu use DEB. Rpms does not understand the "provides" declarations of other debs, that's why you have this misleading dependency errors.

First, I would suggest trying to installing this package of Fedora or Censtos (to make setup smooth), checking that it actually solves your original problem and then you'll know that it worth trouble installing it on Ubuntu.

  • I see. So would you recommend booting with a Fedora from USB, for example, in order to test it? – Itai Bar-Haim Nov 12 '13 at 8:29
  • Yeah, exactly.. – Zaar Hai Nov 12 '13 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.