I have had a fight with my computer for 2 days now.

After running boot-repair multiple times in different ways, it always comes down to this. http://paste.ubuntu.com/6382341/

Also this seems to be part of the problem. ''Locked-ESP detected. You may want to retry after creating a /boot/efi partition (FAT32, 100MB~250MB, start of the disk, boot flag). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot/efi partition:] option of [Boot Repair].''

So I installed Ubuntu 12.04. alongside with pre-installed Windows 8 on Lenovo G500. I used it successfully for a few days for various programming tasks, installing software, plug ins, etc.. Everything worked perfectly. But after that I rebooted to Windows and used that for a day or two. Now a few days ago that I tried to return to Ubuntu, the Grub option doesn't show up at all and I'm directed directly to Windows8 from star up. I tried going to BIOS and Boot menu, but neither of those show Ubuntu. I started my computer now from a USB drive with Ubuntu, and that recognizes that I have Ubuntu installed on my computer already. So the Ubuntu still is there, it's been recognized, but I can't access it.

I have secure boot disabled and from the power options the other option unticked (quick start up or something).

I've gone through a lot of posts and googling for different solutions. But this time nothing seemed to work and I'm helpless.

As far as I have understood the problem of 'No boot loader is installed in the MBR of /dev/sda' is because it's somehow hidden by windows, so I need to make it visible for boot-repair? And this I don't know 'Syslinux MBR (4.04 and higher) is installed in the MBR of /dev/sdb'... I'm quite lost. Help appreciated here, thank you!

  • Please upload gparted screenshot of your drive to imgur.com and post the link here. – Avinash Raj Nov 8 '13 at 15:12

First, the lack of GRUB in the MBR of the hard disk is not a problem, because you're booting in EFI mode, which doesn't use the MBR to store the boot loader. Instead, under EFI boot loaders are stored in the EFI System Partition (ESP), which is a FAT32 partition on which boot loaders are stored as files.

That said, your ESP is /dev/sda2, and according to your Boot Repair output, there's no sign of GRUB on that partition. My suspicion is that this problem results from the Windows Fast Startup feature, which turns shutdowns into suspend-to-disk operations. The result is that filesystems are not properly unmounted, and when they're accessed outside of Windows, filesystem damage can result. Thus, your first task is to disable Fast Startup, as described here (among many other places).

It's conceivable that disabling Fast Startup will fix your problem. If not, you'll need to re-install GRUB or install another boot loader in its place. You can try Boot Repair again for this, but if it fails, I recommend you try the USB flash drive or CD-R version of my rEFInd boot manager. Given your configuration, booting from a rEFInd boot disk should enable you to boot either Windows or Linux. If this works, you can install the Debian-package version in Linux and it should take over from GRUB as your boot manager. If Boot Repair can't write to your ESP, though, it's quite possible that the rEFInd installer won't be able to, either. In this case, you could try following the instructions to install it from Windows -- but be sure to install the ext4fs driver, too. Alternatively, you could shrink a partition by about 550MiB and create a second ESP, unmount the original ESP, mount the new one at /boot/efi, and re-run Boot Repair or try re-installing rEFInd.

  • I tried to run rEFInd boot manager from USB but it didn't work. Also fast startup was disabled already, or at least it's shown by windows to be so. So next I'll probably try creating a new partition for a new ESP. Anyway, there was something interesting I found out. imgur.com/6whOosF The path for boot manager in windows seems to be the grub of my linux. – ITstudent Nov 8 '13 at 18:10

I had the same problem after certain Windows updates: Ubuntu was still installed, but I couldn't boot into it.

And when using Boot-Repair from within a Ubuntu Live USB (2nd option explained in the Boot-Repair wiki), I also got the error message "Locked-ESP detected").

The problem seemed to be that all my partitions were mounted by the Ubuntu Live USB. After starting gParted and unmounting them one by one (right-click -> unmount), Boot-Repair succeeded in repairing my system (using Recommended Repair).

See also this article.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.