I installed mongodb with the instructions here. Fresh installation of ubuntu btw. It installed without error, but upon attempting to start, stop or restart the service, I got

start: Unknown job: mongodb

Invoking "mongod" from the commandline seems to work, as I can view statistics of mongodb fine from localhost:28017.

I've also attempted to use the official ubuntu package "mongodb" instead of "mongodb-10gen" but no luck there either.

  • Try with downloading particular .deb file of mongodb-10gen from Debian install list and installing it with sudo dpkg -i <file name> – user224082 Nov 8 '13 at 5:25
  • Same error. This is the exact link I used downloads-distro.mongodb.org/repo/ubuntu-upstart/dists/dist/… – No_name Nov 9 '13 at 2:50
  • If so, then uninstall it. Install mongodb in Ubuntu repository. Then try with reinstall with that 'mongodb-10gen' .deb file upon Ubuntu repository one. That may be replaced. But see... – user224082 Nov 9 '13 at 3:25
  • Just to note, I tried to reproduce this but cannot - service commands work just fine for me with the 10gen package and ubuntu 13.10 – Adam C Nov 18 '13 at 14:33

Upstart has changed in 13.10 allowing user sessions. So this means that you must execute service like this (even from root account):

sudo service mongodb restart

See this page:


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.