Edit: Trying solution after solution found on these forums with the bootloader has apparently corrupted the bootloader. I missed pressing shift twice in a row and on the third attempt, the bios does not recognize a bootloader anymore. So it looks like I'm starting from scratch.

I am new to Ubuntu and I am using a 1440p & 1080p multi-monitor display setup. Using the default drivers (neuveau?), I am unable to get my display working because when I change my 1080p screen to be in portrait mode instead of the default landscape mode, my 1440p monitor goes black (It's a Crossover 27").

As a result, I assumed that the neuveau drivers won't cut it for my setup. So, I installed NVIDIA drivers for my GTX 680 using this guide: http://www.howopensource.com/2012/10/install-nvidia-geforce-driver-in-ubuntu-12-10-12-04-using-ppa/

After installation and reboot, both of my monitors are now black. I can hear the Ubuntu jingle at the log-in screen. Pressing CTRL+ALT+F1 results in a black screen with a flashing white underscore.

Using just one monitor procures the same results.

I am at a loss of where to go next.

Thanks for your help.

Edit: I decided to try running the following command (In recovery mode):

sudo apt-get purge nvidia-current

This did not resolve my issue. I still boot into a black screen.

2nd Edit: Things are getting stranger now. After attempting to uninstall the video drivers, I booted into recovery mode to try to update my system and reinstall them. After trying the networking option, Ubuntu froze there. So I did Cntrl+C and Ubuntu booted. My primary monitor was still black, but my secondary somehow worked. After logging in, my driver now says GTX 680.

So, I rebooted, and now I'm still back at the black screen on both monitors.

  • 1
    Thank you for your thread Alvar, but the information seems to be unrelated to my issue/outdated information. In your linked thread, there was a solution to black screen problems, found here: askubuntu.com/questions/72245/… This problem was solved by updating the OS. I have the latest version of Ubuntu, so this solution does not solve my problem. Thank you for your help. – Ryan S. Nov 7 '13 at 22:03

First of all remove all remaining nvidia bits and pieces:

sudo apt-get purge nvidia*

Then install the correct drivers:

sudo apt-get install nvidia-current

Don't forget to reboot :)

sudo reboot
| improve this answer | |

This is going to sound insane. Make sure your brightness is up. I had the same problem when I first installed it and my external monitor was good. Then someone mentioned the brightness control and bingo! it worked. After installing three times.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.