7

While installing Wordnet, I'm getting the following error;

stubs.c:132:14: error: ‘Tcl_Interp’ has no member named ‘result’

I tried giving following;

#define USE_INTERP_RESULT 1

at the end of "config.c" file of the Wordnet. Then als its not working. Kindly help.

2
  • Mention the way you tried to install it and your system for better help. (Now with "add comment")
    – user224082
    Nov 7, 2013 at 15:58
  • I found it much trouble to deal with Tcl/Tk, so rewrote the make to produce simple cmdline window: github.com/AncientZygote/WNtight Apr 23, 2020 at 22:18

2 Answers 2

9

The problem is that you try to compile Wordnet with Tcl 8.6.

Tcl 8.5 deprecated interp->result and Tcl 8.6 removed it.

The directive

#define USE_INTERP_RESULT

should solve that, but you should add that in an header file (.h) before you #include <tcl.h>, not in a .c file.

2
  • Thanks for your solution. I gave #define USE_INTERP_RESULT 1 1. In tk.h file in the tk installation directory before tcl.h inclusion 2.In tk.h of the Wordnet include directory before tcl.h inclusion. Then also i'm facing the same error
    – monisha
    Nov 9, 2013 at 5:43
  • 2
    I am ble to resolve the error. I gave #define USE_INTERP_RESULT 1 in the stubs.c of WordNet3.0/src
    – monisha
    Nov 9, 2013 at 6:18
9

In the stubs.c file (which will be found in the WordNet-3.0/srcdirectory include the following directive

#define USE_INTERP_RESULT 1

before the #include <tcl.h>

and the do the make

Not the answer you're looking for? Browse other questions tagged or ask your own question.