3

When my laptop ran XP, the wireless worked perfectly. Now the only way I get internet is having it wired in my living room - which is MASSIVELY inconvenient for me seeing as my room is outside. I have downloaded the driver from 'Additional Drivers', reset my computer (with difficulty, it also doesn't seem to like turning off, so I have to 'kill' it) and still nothing! I have looked all over the internet trying to find solutions but I just cant seem to get it to work. I have a USB wireless stick but I can't load the driver from the CD.

I got this comment on a previous question: "Using either Snaptic Package Manager or Ubuntu's own Software Centre, remove "bcmwl-kernel-source" if it's already installed.

Next, search for "firmware-b43-installer” and “b43-fwcutter” and install both.

Finally, running Software Sources and checking the Additional Drivers tab you should find Broadcom STA Wireless Driver that you can select, install and on reboot hopefully have wireless working ok..."

Which I replied: "Right, so I tried to find/remove "bcmwl-kernel-source" but couldn't find anything. I managed to install both "firmware-b43-installer” and “b43-fwcutter” using terminal, after finding out how it worked. And lastly, I couldn't figure out how to find 'Broadcom STA Wireless Driver' - still no more additional drivers. And my wireless is still not working. My laptop has a button that turns wifi on and off and since I put Ubuntu on it, it hasn't worked. And also, my computer still doesn't seem to restart properly - it just gets stuck on the ubuntu loading screen." - hope that helps, somewhat

I am VERY new to Linux, not very technical and in need of help! -Running Ubuntu 12.04 32bit on a HP Compaq nx6325 Notebook

Thank you to anyone who replies, its much appreciated

2
  • Copy and paste this command in the terminal (ctrl+alt+t)wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named wireless-info.tar.gz in your home folder with wireless information so we can see the condition of your wireless at this time and the Mac address, WPA key and WEP key are removed for your security,paste contents of the wireless-info.tar.gz file as a zip file at pastebin.com. No internet [url]ubuntuforums.org/showpost.php?p=12350385[/url]
    – Wild Man
    Nov 7, 2013 at 15:47
  • pastebin.com/gPkz77Sr
    – user211487
    Nov 8, 2013 at 2:44

3 Answers 3

3

After numerous attempts and many websites... Purging the Broadcom Drivers and installing b43-fwcutter and firmware-b43-installer worked.

  1. Open a terminal using Ctrl + Alt + T or Applications overview → Terminal.

  2. Purge the Broadcom drivers and install b43-fwcutter and firmware-b43-installer:

    sudo apt purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source && sudo apt update && sudo apt install b43-fwcutter firmware-b43-installer    
  3. Remove the EtherNet cable and Reboot.

Reference: Easy Linux Tips Project.

1
  • Why do I need to remove the Ethernet cable?
    – Alvar
    Dec 3, 2013 at 22:40
1

Please do:

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree
sudo modprobe -rv wl
sudo modprobe -v b43

if there are any errors just continue and your wireless should come on. Make sure to unplug your usb adaptor first and after you are done with the commands disable ethernet so wireless can take over.

1

Purging the Broadcom Drivers and installing b43-fwcutter and firmware-b43-installer worked for me:

sudo apt purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source && sudo apt update && sudo apt install b43-fwcutter firmware-b43-installer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.