2

I downloaded Ubuntu 12.04 LTS onto my pendrive using the program recommended. After rebooting the system it showed this error:

[0.032000] kernel panic-not sycning: IO-APIC + timer doesn't work. try booting with
apic=debug and send a report. Then try booting with the 'noapic'option [0.032000]
1
  • What computer system do you use?
    – Manuel
    Nov 7 '13 at 6:38
4

When you first start Ubuntu you need to press the escape key and append "noapic nolapic acpi=off" to the boot options. Your computer is an older model apic isn't compatible with it. My dad's computer is the same way. If you ever get around to installing it on your harddrive you're going to have a doosy. You'll have to go into a liveCD, mount your harddrive as if you were actually using it and then edit your bootloader.

1
  • I get this with creating virtual machine using VirtualBox. How could add that to boo option in VirtualBox?
    – zadane
    Dec 15 '20 at 19:17
0

I faced the same problem on my Lenovo E585. I first added a noapic flag in the ubuntu kernel boot arguments. The Ubuntu started without any problems, but I was not able to suspend(sleep) my laptop (due to APIC being disabled). Then I followed this link and this link and it gives the solution to add this in the kernel boot arguments (in GRUB screen press e and append it to the line starting with linux)

ivrs_ioapic[32]=00:14.0 spec_store_bypass_disable=prctl

Later, I found that this was due to a BIOS problem, that was being fixed in an update by the manufacturer (Lenovo in my case). So, I downloaded the BIOS update from https://support.lenovo.com/bg/en/downloads/ds503790 and after that, my Ubuntu works on my laptop without these kernel boot arguments.

Thanks

M. Saqib

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.