I've got a Bluetooth headset which works great in both Windows 8 and Android 4.2 however on Ubuntu (13.10) it just doesn't seem to work. I installed Blueman, it paired and connected successfully when I tried Audio sink but it still doesn't show up in my Sound Settings nor PulseAudio which I installed and tried. All there is in my Sound Settings is "Analog Output". I tried several fix like changing and adding things in /etc/bluetooth/audio.conf without any success. I've restarted the bluetooth service several times in the process as well.

Let me know if you need more information from me and my system.

Kind regards, Michael.

8 Answers 8


I'm on Ubuntu gnome 16.04. Solution is to enable auto-detection, pair the headset again and select it in the list of output audio devices.

  1. Change #AutoEnable=false to AutoEnable=true in the /etc/bluetooth/main.conf (notice new line is un-commented)
  2. Unpair the headset
  3. Restart the bluetooth service sudo /etc/init.d/bluetooth restart
  4. Pair your headset again and connect it
  5. Go to sound settings. From the output device tab you should now see the headset listed along with other output device like internal speakers
  6. Choose it as the sound output device.
  • Now I have no bluetooth devices at all...
    – Auspex
    Commented Jun 5, 2016 at 16:06
  • when I did that I couldn't pair the device at all anymore. "failed to add device" + some ubuntu internal error Commented Aug 6, 2017 at 10:01
  • These steps worked for me on Ubuntu 14.04, using the SPEEDLINK Vias Nano dongle. Thanks a lot!
    – axel22
    Commented Apr 17, 2018 at 12:03
  • Running this on Ubuntu 18.04 fixed bluetooth not able to connect
    – KhoPhi
    Commented May 27, 2018 at 12:10

I'm with the same problem, after pair the headset, I'm using the pulseaudio -k command, then the device shows up in the Sound Settings and it works.

It's not a good solution, but it was what I got until now.

  • I see I'm not the only one with that specific issue. I'll give you the answer for leading me towards the right path and I'll stay up to date in your question instead. Thanks
    – Michael
    Commented Nov 6, 2013 at 20:44
  • LOL don't say it's not good. It just kills pulseaudio which starts itself up again. that's a very nice and easy solution :D
    – 842Mono
    Commented Jun 27, 2015 at 23:31
  • That worked for me, but afterwards Hangouts doesn't recognize my other headset
    – Alfred Bez
    Commented Nov 17, 2016 at 10:18
  • 1
    On my 16.04 this tip didn't work... :-( Commented Jan 2, 2017 at 14:34
  • Info: -k | --kill Kill an already running PulseAudio daemon of the calling user (Equivalent to sending a SIGTERM).
    – TiloBunt
    Commented Jun 8, 2017 at 6:20

The following worked for me.

There's an option in /etc/bluetooth/audio.conf called AutoConnect=true. Make sure this is not commented (i.e. no hashes) (change #AutoConnect=true to AutoConnect=true)

This will make pulseaudio recognize the device.

Note: For Ubuntu 14 and up, the file is called /etc/bluetooth/main.conf.

  • I think this worked for me. At least I can select the device now. Thanks.
    – jnns
    Commented Jul 7, 2015 at 13:18
  • This worked for me, thanks! After changing this option I had to remove the device from the Bluetooth menu and re-pair it, after it appeared! Commented Jul 24, 2015 at 13:22
  • 7
    I'm on Ubuntu 15.10 Gnome and for me AutoEnable=true in /etc/bluetooth/main.conf did the trick. Thanks.
    – select
    Commented Oct 24, 2015 at 13:34

I'm on Ubuntu GNOME 16.04 and I've found a solution that works perfectly here:


On ubuntu user is gdm and not Debian-gdm, here are the exact instructions:

In order to prevent GDM from capturing the A2DP sink on session start, edit /var/lib/gdm3/.config/pulse/client.conf (or create it, if it doesn't exist):

autospawn = no
daemon-binary = /bin/true

After that you have to grant access to this file to gdm user:

$ chown gdm:gdm /var/lib/gdm3/.config/pulse/client.conf

In order to auto-connect a2dp for some devices, add this to /etc/pulse/default.pa:

load-module module-switch-on-connect


Now the sound device (bluetooth headset) should be accessible through pavucontrol and standard audio device manager.


i've got the same issue on Lubuntu 13.10 with blueman and an wireless speaker adapter. For me the following fixed it:

Insert load-module module-switch-on-connect in the /etc/pulse/default.pa

Command pulseaudio -k

Command pactl load-module module-bluetooth-discover

This module isn't loaded automatically, you have to load it manually. I didn't find a more convenient way.


The only thing that worked for me on Ubuntu 16.04 is to restart the bluetooth service, then reconnect the speaker:

sudo /etc/init.d/bluetooth restart

This seems to happen to me whenever I wake the computer from suspend.


This also still happens in 20.04 ubuntu wayland especially once I come out of suspend.

I used Eduardo's solution up there and it did not work. It just that added 2 more options to my settings > Sound > Output Device Options, But still the Bluetooth device was not included as an option.

Additionally restarting the bluetooth service did it for me.

pulseaudio -k

sudo systemctl restart bluetooth

Its not clean but it works.


Step 1:

mkdir -p ~gdm/.config/systemd/user
ln -s /dev/null ~gdm/.config/systemd/user/pulseaudio.socket

Step 2: REMOVE the paired Bluetooth device Remove device

Step 3: PAIR it again

This worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .