I've followed this guide: https://help.ubuntu.com/community/LiveCDCustomization and when I boot my iso it appears a BusyBox showing this message: "unable to find a medium containing a live file system"" (/var/log/casper.log contains the same). I think the reason is that guide is obsolete. What a pitty!!

Could you show me some light about what can I do to try to solve this problem? I'm really stuck. Thanks, thanks, thanks a lot

P.S: I do not want to use Ubuntu-Builder or similar, because I want to learn how to do it "by hand"

  • That guide looks to be still valid for 2 things that have become old: the ISO mentioned and the part about gconf. The 1st is solved by using a newer one and changing the commands to the new one. The 2nd requires usage of dconf or other methods. But most of it still is valid ;) – Rinzwind Nov 6 '13 at 13:14
  • "unable to find a medium containing a live file system" might mean you need to change your SATA controller type from IDE to AHCI in your BIOS. It can also be a wrong md5hash ( help.ubuntu.com/community/HowToMD5SUM ) It might not be related to that wiki page ;) – Rinzwind Nov 6 '13 at 13:17
  • Well, I'm testing the iso with VirtualBox. I've tried putting both the CD unit and a VDI hard disk too inside the IDE controller mode, and nothing. I've tried putting them inside a SATA -AHCI- controller mode, and nothing. The md5hash is done with this command (executed inside folder will become the iso): find . -type f -print0 | xargs -0 md5sum | grep -v "\./md5sum.txt" > md5sum.txt .Thanks for your answers – Osqui Nov 6 '13 at 19:29

Well, I've found the solution!

I must copy kernel+initrd from squashfs chroot to /casper folder instead of leaving kernel+initrd which are already present there.

This step appears in the guide, but it's presented as something "advanced" - and I guessed that it was "optional" too- under "Live CD kernel" section (belonging to "Advanced customizations" chapter).

Thanks to everyone

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.