I've seen a few similar questions on the web, but none of them solve the problem for me. Essentially random youtube videos won't play in the chrome browser, but work in firefox just fine. Sometimes they even work in chrome on a website that displays the video still hosted at youtube, but won't work if I visit the actual youtube page!

  • Ubuntu 12.04.3 LTS
  • Chromium: Version 30.0.1599.114 Ubuntu 12.04 (30.0.1599.114-0ubuntu0.12.04.3)
  • Chromium plugin: Shockwave Flash 11.2 r202

Here's a few things I've already tried:

  • uninstall and reinstall all flash packages
  • disable all other chromium plugins (vlc, divx, etc.)
  • youtube html5 trial (in/out)
  • using an extension to change my user agent to not chrome on ubuntu

Any help would be greatly appreciated, as I haven't found anyone else with such a persistent problem!

  • 1
    1 2 3 4 5 – Mike Nov 6 '13 at 3:58
  • How about providing some URLs containing the YouTube videos you can't play? – K7AAY Nov 6 '13 at 16:25
  • Note my above comment is 5 links to prior related questions that you asked for. See the answer below that has a couple links posted. I really doubt it's something to do WITH the actual problematic videos, but who knows. – Mike Nov 6 '13 at 21:23
  • Uhh... I didn't ask for the info, someone else did. I wont to check to see if an unusual codec is needed for those videos, and to do that, I need the URLs of the problem videos. – K7AAY Nov 7 '13 at 22:57
  • What version of Chromium are you using? – Braiam Nov 17 '13 at 1:47

One thing that worked for me was disabling the "VLC Multimedia Plugin" in chrome://plugins. Then I discovered this question, which suggested replacing the chromium-codecs-ffmpeg package with chromium-codecs-ffmpeg-extra. One

sudo apt-get install chromium-codecs-ffmpeg-extra

(which automatically removed the non--extra version) later and everything was working perfectly.

  • 1
    Confirmed, installing the chromium-codecs-ffmpeg-extra package fixes this for me as well. – here Dec 29 '13 at 22:04
  • Also solved it by installing chromium-codecs-ffmpeg-extra and restarting chromium. – svz Mar 20 '14 at 19:47
  • I had to restart ubuntu for this to work. (I didn't change chrome://plugins) – idbrii Mar 21 '14 at 1:10

1) have two setups which work differently - same Ubuntu 12.04.03, different arch same Chromium Version 30.0.1599.114 Ubuntu 12.04 (30.0.1599.114-0ubuntu0.12.04.3)

Laptop @ 32bit works Desktop @ 64bit does not work - shows same result as described in this question

2) If I see a problematic video (showing "This video is currently unavailable), I can use the following trick. Click on a working video, than use the "back" button to go back to the not working => voila, it plays. This is very annoying, however.

Hope somebody has some insights, I will try to debug this more systematically when I have time the next days.


I have the same problem but found a workaround: click on a video in the related list, and if it works, click back in Chrome to go back to the faulty video and it will start playing this time instead of showing the error message. Opting in/out and disabling/enabling the flash plugin did nothing for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.