my panel is gone in my updated version of ubuntu. What happened?

lspci shows:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

enter image description here

The panel is shown in normal ubuntu and is not here. The are is outlined in the normal shadow, but the side bar and the panel are showing. However if I slide my mouse across there then the normal volume changer and the like show. Also it has infected my normal ubuntu (classic ubuntu) and the unity panel and siding are making it impossible for me to use my 2 application menus that are in the two right hand corners so I had to add one other to the mix in order to easily access my applications. This thing is getting far out of hand. Need a fix here.

Here's another picture of my problem:

enter image description here

  • @Sam When asked to provide additional information, please add it to the question by editing it rather than as a comment. CapsLock and "HELP ME" comments won't get you an answer any faster so please omit them in the future. – Oli Apr 26 '11 at 22:05
  • Ok sorry I don't quite understand what happened and I just need a tad bit of help I think this question is just dead. I understand that that was unhelpful, but I believe the point of it was to show how little I understand about the problem. – Sam Mercier Apr 26 '11 at 22:24
  • Does the problem persist after restarting x? I've had a few similar glitches when I fiddle with the Compiz settings, but so far they've all resolved themselves by restarting. – keithjgrant Apr 27 '11 at 0:08
  • Does either running at terminal killall gnome-panel or just gnome-panel solves the problem? – desgua Apr 27 '11 at 2:17
  • The problem is still there after restarting and I can't try your idea desgua because I'm away from my computer, but I'll try it and get back to you. – Sam Mercier Apr 28 '11 at 16:20

Sounds very similar to that bug some people are unfortunately experiencing: https://bugs.launchpad.net/unity/+bug/745996

As you can see, it's set to critical and tracked to be fixed in a Stable Release Update during the cycle. However, we have small hints at this stage about what causes it.

All additional information on the bug report it always appreciated :)

It seems that for some people this helped: 1. remove this file from your filesystem: ~/.drirc 2. logout and login again

  • Thank you that sounds promising I'll test it as soon as I can. – Sam Mercier Apr 29 '11 at 16:04
  • I did this and it worked so I think this is a wonderful answer. Thank you so much this sucked until I got it resolved. – Sam Mercier Apr 29 '11 at 21:00

Try logging out and selecting 'Ubuntu Classic' or 'Ubuntu Classic (no effects)' after clicking on your username. Also give Unity 2D a try as it's pretty close to unity.

  • 1
    Sorry that doesn't help much. Ubuntu Classic worked, but recently unity started infecting ubuntu classic and activating itself and I can't stop it. I think that this is some virus or something. – Sam Mercier Apr 28 '11 at 23:46

try to logout (ctrl+alt+del). log in in classic mode. go to ccsm and enable the unity plugin. then logout again, and log in in unity. hope this helps

  • how do I start ccsm? – Sam Mercier Apr 28 '11 at 23:03
  • @Sam Install it, described here – j-g-faustus Apr 28 '11 at 23:30
  • Thanks but it still isn't working. I am afraid that my computer is just screwed. I wonder if I am the only one with this problem. Where should I go to report a bug? – Sam Mercier Apr 28 '11 at 23:44

Maybe you can try these commands:

1. reset the gnome panel

gconftool –recursive-unset /apps/panel

2. remove all the config files

rm -rf ~/.gconf/apps/panel

3. kill and restart the gnome panel

killall gnome-panel
  • Thank you for trying. I doesn't work I think because those are all connected to the GNOME panel and I need the unity panel, but I appreciate your best guess/try. I think because this version of ubuntu is so new no one really knows the source of my problem. – Sam Mercier Apr 29 '11 at 0:52

This is often called by a drawing error inside of your driver. Either FBO support is failing or shader support is failing. Please make sure your mesa and xorg drivers are up to date.

  • Ja... That didn't help thank you though. – Sam Mercier Apr 29 '11 at 23:56

Try these:

  1. Log into classic mode.
  2. Create a desktop Shortcut for CCSM
  3. Now log into Unity. Click on CCSM Desktop Shortcut. Enable Unity plugin if it is not enabled.
  4. Go to preferences, and reset Unity profile to defaults. Logout or Restart your system, log into unity. You should have your panel back now.

Addition Step --> If the problem does not get solved, you may have to use this step as an additional step at number 3 in above list.

Launch CCSM in classic desktop mode, under preferences, under profile click on reset to defaults. With this you may loose any customization you have done so far. Keep that in mind.

  • Ja... That isn't what I needed. That is a different Q already answered. Thank you though! – Sam Mercier Apr 29 '11 at 23:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.