I wanted to bring up an issue with the latest Ubuntu release that I hope can be solved. Although I will agree with the community that iOS 7 is not the most open platform release, it still is my desire to be able to grab Photos, Music, and Files off my Phone similar to what I would do to any other device.

Every time I connect my device to Ubuntu, I receive the following notification:

The device "Justin's iPhone" is locked. Enter the passcode on the device and click "Try again".

On my iPhone, I select the following permissions.

Unfortunately, this is where problems start to arise. It appears that Ubuntu either does not recognize the permissions from my iPhone or the iPhone is not allowing itself to truly be unlocked. As we can see the permissions are denied.

Browsing askubuntu, I encountered the following suggestion.

After running the code, I receive the following error:

justin@justin-CT15:~$ idevicepair unpair && idevicepair pairERROR: Device d1fea2c56e51199f901eb34020a1581ea31a2a50 is not paired with this host

If I call the command again, i receive another error:

justin@justin-CT15:~$ idevicepair pair
ERROR: Could not pair with the device because a passcode is set. Please enter the passcode on the device and retry.

Ultimately, I am stuck to experiment with solutions that end up not working. I am troubled by the lack of information and support for the iOS 7 platform on Ubuntu's latest release. If anyone has a workable solution or experiment for a workaround, I am happy to try

Thanks for reading and have a wonderful day!

  • Just had the same issue with you. There is a bug report here, but it seems no one actually fixed it. Anyway I think the bug is about ios7, rather than ubuntu.
    – Dong Hao
    Nov 16, 2013 at 6:10
  • It appears that we need to wait for Development/Unstable Release: 1.1.6 in order to receive a proper update for iOS7 devices. Until then, the best option is to wait -unless of course anyone wants to take a stab at their repository.
    – justinpage
    Dec 5, 2013 at 21:20
  • There is a workaround, but you have to jailbreak your device. ubuntuforums.org/showthread.php?t=2199251
    – user242143
    Feb 2, 2014 at 21:08
  • I would note that the solution must not include jail breaking. This goes against my original question of connecting iOS7 with ubuntu --within a pure state.
    – justinpage
    Feb 4, 2014 at 1:03
  • 1
    Just wanted to mention that the bug pointed out by Dong Hao is a duplicate of bugs.launchpad.net/ubuntu/+source/libimobiledevice/+bug/1207812 , which is now fixed. A clean install or update to Ubuntu 14.04 should let you use your phone flawlessly.
    – stragu
    Jun 1, 2014 at 23:16

4 Answers 4


This issue is an attempt by Apple to stop the use of fake charging cables. You can solve the trust-loop error with IOS7 mobile devices by installing the latest release of libimobiledevice.

For 12.04:

sudo apt-add-repository ppa:ingo/ios7support
sudo apt-get update
sudo apt-get upgrade

If you get “lock down error”, try using the following commands:

sudo mkdir /var/lib/lockdown
sudo chmod 777 /var/lib/lockdown

For 13.10 you can download the .deb package from the launchpad site here.

For Ipad users that are seeing the 'Not Charging' message on their device when plugged in via usb:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install ipad-charge

Reboot, and enjoy.

  • 1
    You sir are a winner. It worked! ;) Congratulations and enjoy the recognition.
    – justinpage
    Mar 13, 2014 at 19:34

I've gotten it to work by running those commands with sudo at the beginning. Try plugging your iPhone in first and unlock it. When it asks to trust or not, don't tap anything and type:

sudo idevicepair pair

If that doesn't work at first run:

sudo idevicepair unpair
sudo idevicepair pair

If that fails, tap trust or don't trust (try with both) and try the above again. If that fails, then you might have to wait for libimobiledevice to fully update its iOS 7 support.

  • Unfortunately, this does not work. I've tried all permutations that you have offered, and none work. However, I would like to thank you for the suggestion.
    – justinpage
    Dec 24, 2013 at 5:56
  • I'm sorry to hear that. This is what I did with my iPhone 4 on iOS 7.0.2 and it worked. When my laptop was on Ubuntu 12.04, I sometimes had to reboot my iPhone while it was still plugged in, haven't had to do that though on the Ubuntu 13 series, worth a try though Dec 24, 2013 at 6:23

As a work-around to this issue, I found that doing the following would allow me to browse the phone freely with nautilus:

  1. Power cycle phone but do not unlock it
  2. Logout of Ubuntu desktop
  3. Connect the phone to the PC
  4. Log back in to Ubuntu desktop

At this point it seems I can freely browse the phone in nautilus.


Same problem, different solution?

With 12.04 running I plug in the locked iPhone 5s (ios7), answer "trust" or "don't trust" (choice doesn't seem to matter), then ignore subsequent trust questions. It soon stops asking. The iPhone charges, and I can access/download my photos from "home folder".

Not sure what other functions can be done from that point. Not sure this even qualifies as a solution as I don't really do anything technical! Just seems to work if I let it beep a couple of times. I came here searching for the answer, before I found this post it quit asking the trust question and all was good. ASKUBUNTU magic in action!

PS: while iPhone is accessible I unlocked it, the trust question came up again, I answered "don't trust", no changes, still have access, still charging.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .