I made a regular update using update center yesterday on My Samsung NP730U3E with Ubuntu gnome 13.10 and today it won't start. Or rather: it just gives me a black screen. On start up I get to enter my encryption password and everything seems fine. But after the encryption password is accepted it just blanks out.

When I boot into recovery mode and try to boot failsafeX it returns "Fatal server error: (EE) no screens found (EE)"

After booting into recovery mode and "Resume normal boot" I get to the tty1 prompt. If I head over to "tty7", where the graphical things usually are going on I just see this (and it's frozen): enter image description here

What to do?

  • Have you tried tty1 and startx? – Novine Nov 6 '13 at 20:12
  • It gave me a bunch of errors that I kind of understood! :D There was a parse error in /etc/X11/xorg.conf. And modified that file not too long ago, trying to configure touchégg correctly. I will look into this and will return when I've got things sorted out. – lindhe Nov 6 '13 at 20:26
  • Yup. I deleted everything (which was the touchégg configs) from the xorg.conf file, and now everything is working great. Thank you! :) – lindhe Nov 6 '13 at 20:34
  • I'm so glad I could help. If you have more problems you can come to me :) – Novine Nov 8 '13 at 20:02

I had same problem today on Lenovo P50. The issue was that I switching to nvidia driver from stock open source driver. The display would go black when I boot and login gets stuck in loop when I go to recovery mode. When doing Ctrl+Alt+F1 and trying to startx I saw errors such as screen not found. The solution was simply to roll back to stock drives using this command line:

sudo apt-get remove --purge nvidia-*

Voila! I'm back in but then xorg reported some error. So I did,

sudo apt-get install --reinstall ubuntu-desktop

Now there are no issues.



Novine's comment on my question indirectly gave me the answer. When I booted into recovery mode, went on by "resume normal boot" and then logged in via tty1 I ran startx. This gave me an error saying there was a parse error in /etc/X11/xorg.conf. I then opened up that file and emptied that file from some unnecessary lines I had put in there a short while ago (I saved it all empty).

That made the trick, and everything is now working great! Big thanks to Novine! :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.