I was using 13.04 as a guest OS on my Virtualbox 14.2.18. Host is Windows 8. After upgrade to 13.10 ubuntu does not start. I can see black screen and blinking cursor.

Can anyone help? I am pretty new to ubuntu. My feeling is that it is somethign wrong with graphic drivers. I can access tty and all files (/home) are there.

16 Answers 16


This is how I troubleshoot a non-starting Ubuntu in Virtual Box (assuming optimal settings for a virtual machine were already made):

  1. Make sure you had installed the most recent version of Virtual Box.
  2. Try a reboot by entering a TTY terminal (Host + F1)

    sudo reboot
  3. Update the guest OS from TTY (Host + F1):

    sudo apt update && sudo apt dist-upgrade
  4. Install guest additions from command line.

  5. Reboot the guest after installing the guest additions.
  6. Start lightdm manually from a TTY (Host + F1) with

    sudo lightdm
  7. Try several reboots of the VM. Due to timing issues it may help eventually.

  8. Try a reboot of the host.
  9. Check forums and virtualbox.org for known bugs.
  • I've updated VIrtualBox to 4.3.2 and installed additions. Now I see login page from ubuntu. After typing password it shows black screen with popup: "System program problem detected. Do you want to report a problem now?" after pressing Report problem 4 times nothing happens. Black screen is there. – don Nov 5 '13 at 15:31
  • This message is seen on bare metal too - its bugs which may hopefully be fixed sooner or later. Until then your VM may still need occasional reboots, or manual starts of lightdm from TTY. Not much we can do. – Takkat Nov 5 '13 at 15:37
  • is there any way to downgrade or migrate my data from this installation to another? – don Nov 5 '13 at 15:56
  • Downgrade is not recommended. But you could copy & paste your HOME to restore it elsewhere. However I am pretty confident it will be much more stable soon. – Takkat Nov 5 '13 at 18:43
  • 1
    Already solved my issue by Step 2 - thank you! – Nick Coad Jun 20 '16 at 8:49

I had this problem and my solution was simple.

Somehow, my VirtualBox configuration for the VM (Ubuntu) was changed after a Virtual Box upgrade. My guest VM was Ubuntu 64 bits and it was configured as 32 bits version. To change:

  1. Open Virtual Box
  2. Select your virtual machine and click in "Configurations"
  3. Go to "General"
  4. Change the version to "Ubuntu (64-bit)"
  • 2
    Happened to me after transferring machine files to another machine and re-installing virtual box. This fixed my problem. – Orestis P. Jun 10 '16 at 5:42
  • 1
    This really was the right hint for me, to go to the bios and enable Virtualisation. Kudos – Abderrahmane TAHRI JOUTI Mar 16 '17 at 9:38

For me, none of the above answers worked. I solved this problem by disabling 3d acceleration on the vm settings page. This is quite odd since I've been using 3D acceleration flawlessly for months on that VM.


This maybe an answer:

  1. You (and me) get to this screen through an (accidental) host+f9. It doesn't tell you what happened though.

  2. The reverse magic spell is alt+f7 (everything restored in its former glory).

I had to discover this myself. Though getting into trouble was easy enough.


This happens to me today after upgrade VBox to 5.1.30. The logon screen looks normal. After login in, however, the screen becomes black and remain black, while VBox manager preview showing the desktop.

Tried various suggestions, the only thing that works is to disable 3D acceleration for guest OS (Linux Mint18).

Guest addition update has no effect.


I had a similar problem, what I did was:

  1. Enter into Setting --> System --> Processor
  2. Set Processor to 2CPU instead of 1CPU
  3. Click OK and restart.

Worked fine for me after

  • I can confirmed this worked for Xubuntu 18.04 and running on VirtualBox 5.2 on an Ubuntu host. – HotFudgeSunday Sep 28 '19 at 18:22

When I got to the login screen, I turned fullscreen mode off, logged in, then turned it back on. It worked. I might have just been lucky, though.


I had the same issue installing Kali in VirtualBox, blinking cursors on the upper left corner. The simple solution for me was entering BIOS by pressing F10 during boot, and enabling virtualization.


I did the following as it worked for me.

  1. Open TTYL (Ctrl + Alt + F1)

  2. Login to a regular user account (not guest).

  3. Enter sudo dpkg --configure -a

  4. Press (Ctrl + F7)


Here is how I resolved the issue. I had installed Hadoop on my guest openSuse OS. There are several services which needs to be started to start working on Hadoop like,


I added both the above start command in my .bashrc file so that I don't have to start them explicitly everytime I login. .bashrc gets executed every time login.

$cd ~
$vi .bashrc

I commented my start service commands as shown below.

enter image description here


I had a frozen black screen of the graphical interface. An Ubuntu 18.04 VM running on VirtualBox 6.0, on Windows 8 host. Changing the Display -> Graphics Controller to VMSVGA fixed it.

  • Changing from VBoxVGA, booting for the first time, then switching to VMSVGA or VBoxSVGA fixed it for me. – Unknow0059 Oct 29 '19 at 1:52

The following works for my Ubuntu 16.04 inside VirtualBox:

  1. Shutdown Ubuntu guest OS
  2. Go to Settings -> System -> Motherboard
  3. Change Chipset from ICH9 to PIIX3
  4. Restart Ubuntu and the graphics mode becomes normal

Strangely, ICH9 works fine until one day when I upgraded VirtualBox from 5.0.18 to 5.1.28.


Nothing worked, so I booted into recovery mode and selected the DPKG option (repair broken packages) and after that did it.

  • Are you saying that you had broken packages? – user535733 Nov 20 '17 at 16:10

I had the same issue with Linux Mint on VirtualBox 5.2.22.

I could see the boot screen but after boot it would go to a black screen and remain black.

My Base Memory was set at 512 MB. I bumped it to 1024 MB and it got past boot and into the desktop.


When trying to boot Ubuntu on in virtual box I had a black screen until I went into settings > system and unchecked "enable EFI". Ubuntu booted up successfully after I did that.


The following worked for me with Lubuntu 18.04:

  1. Shutdown virtual machine
  2. Go to Settings -> Display
  3. Increase video ram size
  4. Start Virtual Machine again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.