30

This question already has an answer here:

I like having a clock showing the current time and date in the menu bar, but this morning when I logged in it's not there anymore. Everything under System Settings > Time & Date > Clock is greyed out. Ubuntu 13.10 64-bit.

marked as duplicate by user117103, Eric Carvalho, Warren Hill, qbi, Lucio Nov 6 '13 at 21:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

70

This bug has already been reported.

a quick fix (in terminal):

killall unity-panel-service

  • 6
    I had to run the command in sudo mode to make it work (as said in the comments of the bug). If it does not work without sudo for you, sudo killall unity-panel-service. – Lilley Feb 25 '14 at 7:15
  • 9
    Ubuntu 14.04 LTS just presented the same issue. – Telmo Pimentel Mota Jun 12 '14 at 10:51
  • Can confirm - 14.04 regression – Julian Nov 4 '14 at 17:41
  • Just happened to me on Ubuntu 14.04.2 (kernel v 3.16.0-41-generic). The System setting panel for datetime is fully functional but the darn thing does not appear on the Unity bar. Also the above fix did not work. Nor does > dpkg-reconfigure --frontend noninteractive tzdata...... > sudo restart lightdm rebooted the system with nochange after reboot. – Cbhihe Jun 23 '15 at 9:37
  • It might happen after you install the f.lux indicator. – Dan Dascalescu Aug 14 '15 at 9:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.