4

I have a problem with PolicyKit, when I try to install programs in Ubuntu software-center (similar messages in synaptic or muon): The problem started after upgrade from 13.04 to 13.10.

When I try to remove / install programs I get notification:

You are not allowed to perform this action! You don't have the required privileges to perform this action

You are not allowed to perform this action!
You don't have the required privileges to perform this action

When you open details you see this:

org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.44'}): org.debian.apt.install-file

I already checked:

I also tried to add my user to the group root, now my user is in these groups

adm dialout cdrom sudo audio plugdev staff users fuse lightdm mlocate netdev bluetooth lpadmin admin sambashare kismet root

What exactly are the rights, I need to be able to access the software center as user?

Also related to

"Software can't be installed or removed because the authentication service is not available. "


EDIT:
Maybe this problem has to do with it that I also cannot mount USB-devices since the upgrade if I start nautilus as the normal user.

I have to start withgksudo nautilus to be able to mount the USB-stick with the button on the left side (as root then)


Maybe it has to do something with the packages installed, here is the output of dpkg -l

  • The error message in german: "Es ist Ihnen nicht gestattet diese Aktion durchzuführen Sie besitzen nicht die notwendigen Berechtigungen, um diesen Vorgang auszuführen." – rubo77 Nov 21 '13 at 19:55
  • I think a solution is important, cause many users are affected and need a workaround. My current workaround is to use only the cosole with sudo apt-get – rubo77 Nov 21 '13 at 19:56
  • Do you get the same problem when you start your GUI application with sudo in the beginning itself? For example, press Alt + F2 and then type gksu synaptic to start Synaptic and then install/remove the packages?? Be sure that gksu is installed in your system. Reply.. – Saurav Kumar Nov 24 '13 at 12:10
  • No, then everything works fine as root – rubo77 Nov 24 '13 at 15:52
  • Have you tried to re-install software-center and other GUI packages after completely removing it? Since the steps are quite long I prefer to post it as an answer. Just give it a try, hope it would work.. – Saurav Kumar Nov 24 '13 at 16:52
1

Try to completely remove Software Center and then re-install it

These commands will help you.

sudo apt-get autoremove software-center && sudo apt-get --purge remove software-center
sudo apt-get autoremove && sudo apt-get autoclean
sudo rm -r ~/.cache/software-center/

Please read the messages carefully, be sure that it removes packages related to software-center only.

Now re-install it again:

sudo apt-get update
sudo apt-get -f install software-center

Edit

Sometime you've to manage with some other way. I did what I could do. I guess the problem is when you click the install button in any package manager it doesn't invoke the password window to get the password. But when you open the package manager with the appropriate permissions it would not be needed and simply all work fine..

So what I suggest you to stick with the workaround what I told you before, i,e run package manager each time by pressing Alt+F2 and executing the command with gksu. Like gksu synaptic or gksu software-center.

It is not a big issue to use, because although you've to give your password in order to install/remove packages. At last I will say sorry that after spending that much time your problem has not been solved. :( I hope you would manage with the workaround what I suggest you earlier.

And yes you can get the list of broken packages and residual packages with this command:

sudo dpkg -l | grep -e "^rc" -e "^iU"

If this command returns any value this means that you've broken packages or residual packages. rc means residual and iU means broken.

Reply if I can help you further..

  • I tried, but it didn't change anything, here the install log: pastebin.com/ubYwv6UT – rubo77 Nov 24 '13 at 17:42
  • That's all I can help you.. :( Although I saw a lot of rc (residual configuration) packages in your system, that should be removed. I don't whether it would help you but you can at-least try it. You can remove all of them using the command that I've mentioned in this post Residual packages Ubuntu 12.04 – Saurav Kumar Nov 25 '13 at 7:58
  • I removed all rc packages now, but no effect unfortunately. I updated the packagelist on gist – rubo77 Nov 25 '13 at 13:08
0

I started getting the same message. Then I discovered I had accidentally unchecked PolicyKit in my [Settings Manager] [Session and Startup] [Application Autostart].

I use Ubuntu Studio.

  • Not in my case. – rubo77 Dec 1 '13 at 6:04
0

Upgrade to 14.04 fixes this problem

0

Had the same problem and discovered this article.

It tells you to install the gdebi package:

sudo apt-get install gdebi

Then you can right click on the .deb file, select 'open with' and select gdebi instead of the software center. This one then worked asking for the password when installing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.