I just installed Ubuntu 13.10 from a live cd via Live Linux USB creator. It installed with no errors. I put an encryption password on the hard drive, then created my user account with a password. All of the installation was completed and the computer restarted. Back at the logon screen, I see "NedryOS", Guest, and Remote login. I click on NedryOS and enter my password and hit enter. In the space of less than a second the following happens:

  1. a loading circle appears in the password box. I assume this is normal.
  2. the login screen disappears and goes black. I have no idea if this is normal
  3. vertical white lines flash on the right side of the of the screen, about a third of the width of the screen then disappear
  4. very small white dots, or perhaps <10 pixel wide lines (definitely smaller than the text entry line that appears on the console) flash across the whole screen, but not in any apparent pattern
  5. the top two lines (character size lines i mean) appear with red lines across the width of the screen
  6. there are two beeps, that are very freaking loud, by the way. they are the same that happen when the login screen first appears.
  7. back to the logon screen.

Well, crap. Things I've tried so far:

  1. Guest session -- works normally, including internet access with firefox
  2. putting in an obviously wrong password -- "invalid password" appears
  3. restarting using this method (including remounting) setting the password to "1" -- same issue as before
  4. reinstalling Ubuntu 13.10 from the same usb drive with no hdd password -- same issue as before

This is the computer I have, with no modifications, and prior to installing Ubuntu, I completely wiped the drive. I also have full power and it's plugged in, so that's not it either. I have been searching askubuntu for responses for the same issue, and have only found solutions for people who lost their password, which I obviously did not if I was able to change it.

I will say that I am a first time user, so I've no idea if it's a pebkac error that is completely going over my head.

Thanks for any assistance you can provide.

I found this solution and it cleared some of the graphical errors. It does still return to the login screen, but here's what happens:

  1. enter correct password
  2. loading circle
  3. black screen with mouse
  4. black screen no mouse
  5. black screen with mouse
  6. login screen

Again, it takes only a few seconds, but there were no beeps this time. I will continue to search for solutions and update as I find them.

This solution also did not work for me. I performed both steps. I do not have a .Xauthority file, and my /tmp file now reads exactly as it says there. I am still experiencing the login loop.

This solution did not work.

I do not have a .Xauthority file, so no solutions involving that will work either.


So I'm not really sure this should really count as a fix, but whatever. I reinstalled Ubuntu 13.10 from the same disk and same file, but this time I checked one of the boxes that said login automatically. It logs in automatically now, and to make sure it worked completely, I locked it, and logged back in fine, then logged out and logged back in fine. I'm not really sure I won't have the issue again later.

Based on the number of login loop posts, I would recommend trying all of the other solutions above before this, because in the long run, those should work while this might not.

  • 1
    Please don't post a fix as part of the Answer - remove it and add it as an answer. This makes it easier for others with a similar problem to find and also means you can earn some reputation. – Warren Hill Nov 5 '13 at 6:58

Maybe you changed permissions on your /home/user folder. Try running this in a terminal:

chmod 777 -R /home/user

It worked for me

  • "multiple solutions failed" is being used as an excuse for posting a 777 permissions VLQ answer. – karel Jul 8 '19 at 10:49

Try re-installing your Display Manager (DM).

Log-in to a new tty (press ctrl + alt + F1) and enter the commands;

sudo stop lightdm
sudo dpkg-reconfigure lightdm 

then choose gdm as the default DM. After having done that, restart the system to see gdm in effect using command:

sudo reboot

But if want lightdm back, open a terminal and enter:

sudo apt-get install lightdm

Then go to a tty (press ctrl + alt + F1) and enter the following:

sudo stop gdm
sudo dpkg-reconfigure gdm

and choose lightdm to be your default display manager. Restart the system with:

sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.