I'm running 64-bit Ubuntu 12.04 (kernel 3.2.0-55-generic). I have a 32GB USB drive which I'm unable to mount on this system. Any help appreciated.

The USB drive shows up as /dev/sdb in the 'disks' utility as device=/dev/sdb but no entry for media, size and contents.

Even dmesg shows the usb device as attached (but not mounted) to sdb:

root@ms-dell:/media# dmesg | tail
[74087.307755] usb 3-1: new high-speed USB device number 19 using xhci_hcd
[74087.476039] scsi22 : usb-storage 3-1:1.0
[74091.448070] scsi 22:0:0:0: Direct-Access     Generic  USB  SD Reader   0.00 PQ: 0 ANSI: 2
[74091.450061] sd 22:0:0:0: Attached scsi generic sg1 type 0
[74097.787512] sd 22:0:0:0: [sdb] Attached SCSI removable disk

However, fdisk -l does not show the disk

root@ms-dell:/media# fdisk -l
Disk /dev/sda: 256.1 GB, 256060514304 bytes
255 heads, 63 sectors/track, 31130 cylinders, total 500118192 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3e828130

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048      616447      307200   de  Dell Utility
/dev/sda2          616448     6907903     3145728    c  W95 FAT32 (LBA)
/dev/sda3   *     6907904   468371455   230731776   83  Linux
/dev/sda4       468373502   500117503    15872001    5  Extended
/dev/sda5       468373504   500117503    15872000   82  Linux swap / Solaris

Nor does the Nautilus.

I initially thought MBR to be corrupted so tried to fix it using dd but got the following error:

root@ms-dell:/media# dd if=/dev/zero of=/dev/sdb bs=512 count=1
dd: opening `/dev/sdb': No medium found

Is there a way to repair the USB drive and access its contents?

  • Did you solve the problem? Can you give some pointers if such a USB is repairable? Thanks. Oct 4, 2014 at 11:14

1 Answer 1


You said you're unable to mount the drive on this system, does this mean that you have successfully mounted the drive on another computer or system? If so, the drive is not faulty and you shouldn’t be using dd on it, especially if you care about the data on it anyway.

Have you ruled out a faulty USB port or a low Voltage in all the usb ports of your PC? Try plugging in another device in the same port, it works right?

If you're ruled this all out, then try this: type lsblk in a terminal, before you plug in the faulty drive. Then again type lsblk after you plug it in. Does it get detected? What filesystem was on the drive anyway?

Have you tried sudo mount /dev/sdb1 /somefolderyouhavemade ??

  • 1- The usb drive is undetected on other computers. That was the first thing I tried. The intent of running dd was to try to recreate the MBR and see if that fixed the issue.
    – user211437
    Nov 7, 2013 at 21:53
  • 2- The usb ports are good because other USB drives are being detected on the same port.
    – user211437
    Nov 7, 2013 at 21:54
  • 3- lsblk did not detect the device and trying to mount the drive results in the same error as earlier with dd sudo mount /dev/sdb /mnt/usbd mount: no medium found on /dev/sdb
    – user211437
    Nov 7, 2013 at 21:56
  • The usb drive is undetected on other computers. That was the first thing I tried. That's also the first thing you should have mentioned. I can't help you with a broken drive, personally I think there's not much you can do unless you understand electronics and fix the drive itself.
    – user824924
    Nov 8, 2013 at 22:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .