0

What I've been trying to do is partition my 600GB harddrive 4 ways and install three OS.

Partition 1, 16GB: WindowsXP x32

Partition 2, 16GB: Ubuntu 12.04

Partition 3, 30GB: Windows7 x64

and finally the last partition with the rest of my space for storage.

However, I have reformatted and reinstalled all these OS maybe 5 times yesterday trying to figure out how I would do it. After the first two installs, I realized I had to install the OS in a specific order. The next few installs where faults in how I was splitting the partitions. The last time I did it last night, it appeared as though I installed it all right, as Grub would boot up, from there I could hit Windows then the Windows loader would appear with 'Older Windows' and Windows7 as options. So I went to bed satisfied without actually checking it. Now, woke up, tried to boot Windows7...it appeared that the Windows7 partition magically disappeared.

Anyway, I just installed everything 'again', with this setup; Split all the partitions and make them all 'primary', install WindowsXP

Install Windows7

Test to make sure Windows7 and XP both boot up.

Since they did, install Ubuntu from a Live CD.

Grub didn't pop up automatically at this point. Boot still loaded Windows Loader.

So I used the Live CD to run Boot-Repair.

Boot-Repair worked without any errors, so I restart

Grub doesn't appear, but Ubuntu loads automatically. I was also holding Left-Shift though the boot process just in case.

At this point, I'm not sure what to do to make Grub appear. So I look online and find out there is a config file you can 'commit' a line out of for the 'grub timeout' or something, so I do that. Grub still doesn't 'launch'. Go back into ubuntu, go to install Boot-Repair, but it gives this error in the terminal;

'Installing rEFInd on Linux....
//boot/efi doesn't seem to be on a VFAT filesystem. The ESP must be
mounted at //boot or //boot/efi and it must be VFAT! Aborting!
dpkg: error processing refind (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up gawk (1:3.1.8+dfsg-0.1ubuntu1) ...
Setting up glade2script (3.2.2~ppa45~precise) ...
Setting up boot-sav (3.199~ppa33~precise) ...
Setting up boot-repair (3.199~ppa33~precise) ...
Setting up boot-sav-extra (3.199~ppa33~precise) ...
Setting up python-configobj (4.7.2+ds-3build1) ...
Setting up pastebinit (1.3-2ubuntu2.1) ...
Errors were encountered while processing:
refind
E: Sub-process /usr/bin/dpkg returned an error code (1)'

So, I've been having alot of harsh luck with multi-booting so far. Is there any way to fix the above error without having to reformat 'everything' again, while at the same time make grub show and Windows options for loading? I'm convinced I'm doing something wrong, but I'm not sure what. And, it it matters at all, I apparently have something called a 'UEFI' bios or something? I have no idea what that means, but it seems to have come up quite a bit in all my googling, so maybe that's the cause of all my suffering?

Thanks in advance for reading all this, but yeah... Halp?

0

I'm about to sleep so I apologize in advance for jumping to a conclusion. But the impression I'm getting is that either you are having problems on where to install GRUB 2. Can't tell much, but could you boot your computer via a Linux Live USB (i.e. Ubuntu) and then run GParted, then take a screenshot?

Below is not a solution, but an advice to share a personal "best practice" when multi-booting:

  1. Order of install is all MS Windows OS first (oldest to newest, so in your case install XP first and then Windows 7).
  2. Last will be your Linux Operating System/s.
  3. If you are multi-booting, say two (2) MS Windows OS's and two (2) Linux OS's, install the MS Windows OS's as per #1. And then for the Linux OS's, just be reminded that the last Linux OS you install is the one that will take over the "Bootloader" (GRUB is an example of a "bootloader").
  4. The best tip that I follow when multi-booting is to learn how to install GRUB 2 in a "dedicated" partition.

This way, you avoid the issue where your MS Windows OS "magically disappeared"...you can actually check if the MS Windows installation really disappeared or got deleted by booting a Linux Live USB of your choice and then try checking in the File Manager if the MS Windows partition is still there.

And if it's still there, then it narrows down your problem to how the bootloader (i.e. GRUB 2 in Linux) got installed.

When you opt to install GRUB 2 in a "dedicated" partition, it frees you from the worry of the bootloader being deleted along with the respective OS partition, or other complex scenarios. At least, the working OS that was installed will boot up properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.