I have just finished an install of ubuntu 11.04 beta 2. At the end of the installation I got a message informing that I do not have the required hardware for unity, and that I should choose "ubuntu classic".

Could someone please shed some light on how to fix this? I have tried adding the "experimental 3d xyz" driver but still no luck. When I log out and try log back in there is no option for unity.

My graphics card is an nvidia 240gt or gt240, I cant remember now which way around it goes.

I enabled "experimental 3d support for nvidia cards" - this is what I was reffering to above, not a driver - sorry about that.

Experimental 3d support

  • 1
    What kind of video card to you have?
    – Egil
    Commented Apr 26, 2011 at 10:15
  • 1
    Please edit your question and give us details on the driver you installed. An "experimental 3d xyz" driver does not exist.
    – Takkat
    Commented Apr 26, 2011 at 10:29
  • requested info added.
    – Craigt
    Commented Apr 26, 2011 at 11:14
  • just upgraded for 11.04 and i have the same problem! help! nvidia geforce go 7300
    – suli8
    Commented Apr 28, 2011 at 18:51

9 Answers 9


There is bugs reports for this issue at launchpad: jockey/+bug/771788 e nvidia-graphics-drivers-173/+bug/772207. Add your card details then mark it to report that you have the issue. Hopefully, it will be fixed soon!


I have had problems with my nvidia card as well, and I think my answer to a similar question might help you. It list all my attempts (everything I found), plus what finally worked for me: adding nopat to the kernel parameters when booting. It is a known problem with nvidia cards.

For this case, what I hope should work is:

  • use the 173 version of the nvidia driver
  • force starting unity, by adding UNITY_FORCE_START=1 to /etc/environment
  • the nopat did no difference for me :-(
    – aioobe
    Commented Sep 11, 2011 at 6:24

It appears to be a bug at the app that checks for drivers update - jockey see this.

You can test if it is in use at least in three ways. Check the commands and the outputs following:

/usr/lib/nux/unity_support_test -p  

enter image description here

lspci | grep nVidia  

enter image description here

sudo lshw -C display

enter image description here



I have same configuration and exactly same message as you. But phrase "driver not currently in use" is false. Driver IS used. Check glxgears, if you have ~7800 fps, just relax.


To quote your screenshot,

This driver is activated but not currently in use.

Have you restarted after you installed the Nvidia driver? You can't use it as long as the old driver is still loaded in the kernel.

  • BTW, I have GT240 and Unity works just well out of the box...
    – Extender
    Commented Apr 26, 2011 at 12:36
  • I have the same problem. After I reboot, and got no luck. What could I do next? thank you~
    – sam
    Commented May 11, 2015 at 5:16

Proprietary drivers in Ubuntu are drivers for your hardware devices that are not freely-available or open source, and must be obtained from the hardware manufacturer. The free and open source video driver, Nouveau, is the driver Ubuntu will use as the default for Nvidia graphics cards. Nouveau does not have support for 3D and may not work at all with latest video cards from Nvidia. Proprietary drivers, closed source, are the alternative for Nouveau, and most time provide superb 3D acceleration and overall video card support/performance. Follow these instructions to install proprietary drivers for your Nvidia Graphics Card.

enter image description here


I had this same issue, but none of the answers here fixed it for me. I eventually fixed it by doing this:

sudo modprobe nvidia

Which gave me a warning that nvidia_319 was actually blacklisted somehow...? So I did:

$ cd /etc/modprobe.d
$ sudo fgrep nvidia * | fgrep blacklist

which informed me that my earlier install of bumblebee was breaking the regular nvidia drivers. So I did:

$ sudo apt-get remove bumblebee
$ sudo rm bumblebee.conf

And that fixed the problem. If you have this problem, it may not be this exact issue with bumbleebee, but if your nvidia drivers are somehow blacklisted, this method will tell you what is blacklisting them and why, and you can attempt to deal with it that way. The "Additional Drivers" menu and jockey-text -l will not inform you that this could be a blacklist problem.

If the above or any of the other answers do not help, make sure that nouveau is blacklisted and then reinstall the nvidia drivers. Installing nvidia should do this for you, by making a file something like this (but if it doesn't, copy this one and make sure to blacklist all the drivers but the one you don't want to use)


blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
alias nvidia nvidia-current 

You can check unity-2d as it will be the fallback environment from 11.10. As far as I understand, your graphics card does not meet unity 3d requirements which is the default desktop environment. You may try gnome classic desktop which is still available.

See here for information on hardware requirements.

Checkout this for installing unity-2d. In 11.04 you can install unity-2d:

EDIT: As I see the screenshot, I can only recommend a single active driver rather than both. I think there are a lot of issues regarding newer Nvidia and Ubuntu


I think you have the nvidia driver installed as a deb package but not the driver itself so you need the kernel headers for that i think from the terminal

sudo apt-get install linux-headers-2.6.38-8-generic-pae
sudo apt-get install linux-image-2.6.38-8-generic-pae

or just look for them in synaptic

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .