I've installed Wine 1.7 with Winetricks on Ubuntu 13.10 Saucy Salamander. I've tried to launch any .exe files, but still is a problem:

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file: No such file or directory

I've found a few tips, but anything doesn't work. How can I solve it?



I just had the same problem. For me, it was sufficient to install the i386-version of p11-kit using

sudo apt-get install p11-kit:i386

I'm using Ubuntu 13.10 64-bit.

  • 14
    For me this conflicts with 64-bit version :-( (Ubuntu 13.10 64-bit). Apt says: "The following packages will be REMOVED: gnome-keyring p11-kit python-ubuntu-sso-client ubuntu-sso-client" . – sumid Jan 26 '14 at 13:38
  • this seems to be still an issue with Ubuntu 16.04, for me it wanted to remove evolution-data-server gnome-keyring p11-kit skypeforlinux – Dennis Nolte Jul 25 '18 at 7:53

I had the same problem and solved it in a very simple way:

All you have to do is to install the p11-kit-modules:i386 package. You can do that like this:

sudo apt-get install p11-kit-modules:i386

And that's it, p11-kit-trust.so is part of this package and will be installed in its correct place.

Hope it helps ;-)

  • On a x64 system, this is most likely the most correct answer. Especially if you already have gnome-keyring installed. Thanks! – Alex Summers Jun 24 '17 at 7:27
  • this does not try to remove packages on my ubuntu 16.04 x64, so this is the better answer in my opinion. – Dennis Nolte Jul 25 '18 at 7:54

I just downloaded p11-kit:i386 with apt-get download, extracted the /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so file (with Archive Manager) and copied it to my /usr/lib/i386-linux-gnu/pkcs11/ folder.

Hope this helps others to solve the problem without having to install other software.


You could try to follow this other thread and perform as it mentioned over here

If you are on Ubuntu saucy salamander (e.g. 13.10 beta 1) and you get the error message

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so: cannot open shared object file: No such file or directory

then simply follow the same commands as in the above link, but also with p11-kit: first do

sudo /usr/local/bin/getlibs -p p11-kit:i386 

then make the symbolic link:

sudo ln -s /usr/lib32/i386-linux-gnu/pkcs11/p11-kit-trust.so /usr/lib/i386-linux-gnu/pkcs11/p11-kit-trust.so

Reggie Sep 17 at 17:38

  • On a shared WOW64 wine setup this results in wine complaining about the architecture of the shared object. – Wolfer Feb 25 '14 at 19:42
  • On Saucy, I got a conflict when trying to install p11-kit:i386, and getlibs was trying to install ia32libs, which no longer exists. sudo aptitude install lib32z1 lib32ncurses5 lib32bz2-1.0 and then the symbolic link in this answer worked to get rid of the error message in wine. – naught101 Mar 13 '14 at 3:55
  • I think this worked - I'm at least on to the next bug. I had to first create some directories I didn't have though. ie mkdir /usr/lib32 /usr/lib/i386-linux-gnu/pkcs11 – mc0e May 4 '14 at 12:45

A few of the other answers suggest doing this:

sudo apt-get install p11-kit:i386

This causes conflicts for me, and deinstalls gnome-keyring, which is a pretty bad thing. It stops ssh from remembering passphrases, and thus you have to keep typing your passphrase in the terminal every single time. And it stops Network-Manager from being able to ask for WiFi passwords.

The one answer that works is

sudo apt-get install p11-kit-modules:i386

This doesn't have any conflicts.

Manually unzipping packages and installing files is also not a good idea, since you won't automatically get updates, which can lead to security issues.

(Wanted to comment on the correct answer post, but wasn't allowed due to lack of reputation. Figured I'd post to clarify the details for people.)

  • -1 for: this question is two years alt, the ubuntu version outdated and the problem, I am sure, is gone for a long time – cmks Mar 16 '16 at 16:24
  • 5
    Nope. The problem is still around with PlayOnLinux. – DocWilco Mar 18 '16 at 20:00
  • -1 as it copies only other answers. The problem itself still happens. – Dennis Nolte Jul 25 '18 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.