2

Has anyone successfully installed Ubuntu on the new MacBook Pro (late-2013)?

If not, what issues have you had?

If so, did you use a tutorial, which one?

5
  • Have you tried to install it? Ubuntu should be smart enough to no to give problems.
    – Braiam
    Nov 6 '13 at 11:52
  • 2
    Your question is worded in such a way that people will turn away from it. It assumes 1. someone has a new MacBook. 2. someone wants Ubuntu on it 3. someone is registered here and 4. is willing to post all that went wrong with their installation. Question have a lot more traction when you run into problems trying to install Ubuntu and ask about those problems. The problems you run into do not need to be because of using a Mac so might have a wider audience ;)
    – Rinzwind
    Nov 6 '13 at 12:31
  • Besides all that: I went on a searching spree and below is the best I could find :) (even though I do not own a Mac (and never will :D ))
    – Rinzwind
    Nov 6 '13 at 12:32
  • 1
    Oh come on @Rinzwind, MacBooks are great ... for installing Ubuntu on :-). I got my MBP in 2011, after 15+ years on Linux. The single thing I'm sorry about is that I didn't put Ubuntu on it earlier :D.
    – zwets
    Nov 7 '13 at 19:19
  • Oh the hardware is astonishing. It's the companies morals I detest ;) @zwets
    – Rinzwind
    Nov 7 '13 at 20:16
4
+25

I have not found anything on the web related to 11.2 or 11.3. 11.1 is the closest I got and is also late 2013. Assuming no regressions this is the best you get:

Has anyone successfully installed Ubuntu on the new MacBook Pro (late-2013)?

See below; last blockquote.

If not, what issues have you had?

Doesn't work:

  • Speakers
  • iSight
  • Suspend / Resume (resumes to black screen)

Source: conan.jen@ubuntuforums.org.

If so, did you use a tutorial, which one?

  1. Downloaded 13.10 NON-MAC iso.
  2. Put it onto flash drive via unetbootin.
  3. Boot up with option held at startup, and select the usb drive.
  4. Upon installer bootup, went into advanced section and deleted all partitions.
  5. Created an efi boot partition at 200mb. Installer should auto set the mount point on that partition to /boot/efi, but make sure.
  6. Created a normal ext4 partition mounted to /, for the system installation point.
  7. Continued on setup.

Source: conan.jen@ubuntuforums.org.

Thank you Conan for your lead! I have successfully installed Ubuntu 13.10 on a MacBookPro11,1 (Retina, 13-inch, Late 2013). The installation went smoothly but I could not boot into Ubuntu. After hours of trying, I finally figured it out. The following are what I did (same steps as Conan's except Step 5):

  1. Download 13.10 NON-MAC iso and put it onto flash drive via Startup Disk Creator (or unetbootin).
  2. Boot up with OPTION key held, and select the EFI icon to boot the flash drive.
  3. Enter live mode (i.e. "Try Ubuntu").
  4. Install. Wipe out existing partitions and create new ones: i) 200MiB efi, bootable, mounted to /boot/efi; ii) 20GiB ext4, mounted to /; iii) 8GiB swap; iv) rest ext4, mounted to /home.
  5. After installation, fix the EFI boot order (The EFI BootOrder was 0080 but ubuntu was listed as Boot0000*).

    sudo apt-get install efibootmgr sudo efibootmgr ## display boot order information
    sudo efibootmgr -o 0 ## set boot order to 0000 first
    sudo restart -r now
    
  6. Edit grub configuration file /etc/default/grub (one line):

    GRUB_CMDLINE_LINUX="libata.force=noncq" and then 'sudo update-grub'
    
  7. Install kernel 3.12. Thanks, kjano!
  8. Fix speakers (following https://bugs.launchpad.net/ubuntu/+bug/1247475). Thanks, kjano!

(There is no need of rEFIt or rEFInd or boot-repair. I wasted hours trying various options of boot-repair to no avail.)

Source: lichun1668@ubuntuforums.org

1
  • I just hope those aren't real mails :S
    – Braiam
    Nov 7 '13 at 18:41
0

Speakers also fixed for 11.3 using mba6 model setting.

for 11.1:

sudo apt-get install alsa-tools
sudo hda-verb /dev/snd/hwC1D0 0x1 set_gpio_data 1

for 11.3 also set mba6 not mbp101: Refer this bug.

HDMI to VGA (e.g., for projector) requires and active adapter (that uses USB as power supply) but works fine. HDMI to HDMI works out of the box.

See this for updates.

0

I have installed ubuntu budgie on my 2010 macbook pro and I have not faced any issues. I did face issues when trying to load ubuntu 19.04. Ubuntu budgie 19.04 was working ok but was slow. But ubuntu budgie 19.10 works seamlessly and I have not faced any issues so far. I used rufus to create the boot drive.

-1

Install iubuntu for macs, http://releases.ubuntu.com/saucy/ubuntu-13.10-desktop-amd64+mac.iso , on a USB, and then use boot camp (preinstalled) to walk you through the steps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.