1

I'm running Ubuntu12.04 and I'm trying to get a TP-Link TL-WN821N to work. The solution from Internet Timeouts with TP-Link TL-WN821N v2 wireless usb stick didn't work for me. Neither has anything else...

I've installed rtl8192cu as per instructions I found elsewhere to no avail.

The symptoms I am experiencing are: When I plug in the device the PC can see and connect to wireless networks fine. The network I'm using has internet access and the signal strength is pretty strong. I can't ping and I can't browse the internet (timeout).

Any ideas? I'm not sure what the next step would be or what information would be useful at this point.

  • Thank you very much!! Your solution is awesome and work perfectly! I had another solution that I found although the connection sometimes was falling. I imagine that the driver would be a little different. This drivers work perfectly ;) I've tested with Ubuntu 12.04 and TP-Link (TL-WN821N) – user257084 Mar 11 '14 at 12:38
2

First of all, ensure you have the necessary prerequisites:

sudo apt-get install linux-headers-generic build-essential dkms git

Clone the updated driver with git:

git clone https://github.com/pvaret/rtl8192cu-fixes.git

Set it up as a DKMS module:

sudo dkms add ./rtl8192cu-fixes

Build and install the driver:

sudo dkms install 8192cu/1.9

Refresh the module list:

sudo depmod -a

Ensure the native (and broken) kernel driver is blacklisted:

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/

Let's not take any chances. Instruct Ubuntu to load the new driver when it starts up.

echo 8192cu | sudo tee -a /etc/modules

Reboot.

You're done.

Thanks to P. Varet for this awesome fix.

| improve this answer | |
  • Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such. – RolandiXor Dec 25 '13 at 6:25
  • Thanks, really works!. As of today there is a change: replace: sudo dkms install 8192cu/1.8 with: sudo dkms install 8192cu/1.9 – Julio Diaz Sep 29 '14 at 21:28
  • Thanks for the update, @JulioDiaz! I've updated the post with the additional info! :) – SirCharlo Oct 6 '14 at 19:42
  • 1
    This just broke my Ubuntu 14.04 instalation. I can login but after that I can only see the mouse pointer and the dsktop background. – Tomas Romero Nov 16 '14 at 2:50
  • Yup, made it on Ubuntu 16.04 and it broke my dual-boot OSs – Praytic Jul 3 '16 at 8:18
1

@SirCharlo's solution not working for ubuntu 14.04.

Please follow this link for instructions: https://sites.google.com/site/easylinuxtipsproject/reserve-7#TOC-Realtek-RTL8192EU-chipset-0bda:818b-

Contents

  1. Determine the chipset
  2. Realtek RTL8188CUS and RTL8192CU chipsets (0bda:8176 and 0bda:8178)
  3. Realtek RTL8723BE chipset
  4. Realtek RTL8192EU chipset (0bda:818b)
  5. Realtek RTL8812AU chipset (0bda:8812)

This driver package is an improved version of the driver package that the Maxxter company provided for a wireless dongle of theirs. The original driver only works in Xubuntu 12.04 and Linux Mint 13, but the improved version also works in Ubuntu 14.04 and Linux Mint 17.1.

| improve this answer | |
0

Try this: After execute the two first steps reboot the pc. Continue with next steps. And if you have an error when execute "sudo dkms install 8192cu/1.9", you must change "1.9" for "1.10", it is because kernel was updated. This worked for me, I'm using Ubuntu 14.04.

| improve this answer | |
-1

I had the same problem and solved it by disabling the power management feature. Just follow the troubleshooting section over here

Gilad

| improve this answer | |
  • 4
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eric Carvalho Feb 27 '15 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.