I visited a lot of forums but found no answer. I have 5 files in my trash bin and I can't delete them, at first after I clicked on the empty trash button it would freeze, now when I do that it just says "preparing" and displays an error while trying to delete files.

I tried deleting it via BleachBit but nothing, tried with terminal command sudo rm -Rf ~/.Trash/* it doesn't work either. I found out that one of my folders is immutable, I tried to disable that via terminal it didn't work, I can't even restore it, it freezes again.

I've been using Ubuntu 13.10 for few weeks and I am new to Linux. How can I solve this?

  • 2
    Isn't trash in ~/.local/share/Trash instead of ~./Trash? (~ represents the home directory by the way). So rm -rf ~/.local/share/Trash may work, but try not to remove anything important. If you are VERY sure you could run it as root, but then you would need to run sudo rm -rf /home/USERNAME/.local/share/Trash instead. Be careful with the -f option.
    – Wilf
    Nov 3, 2013 at 14:48
  • 1
    @Lucio A new Q should get closed by Old Q as duplicate.
    – Raja G
    May 19, 2014 at 14:42
  • 2
    @raaz that is a stupid rule
    – Lucio
    May 19, 2014 at 16:18
  • 4
    @raaz there's no rule that states so. The question with better quality answers should be the master.
    – Braiam
    May 19, 2014 at 18:19
  • @Braiam Look at the answers, they are same. you dont even look. bravo
    – Raja G
    May 20, 2014 at 5:58

1 Answer 1


Open your terminal and type the following command to clear the trash

 sudo rm -rf ~/.local/share/Trash/*
  • 1
    It worked thank you! why is not the official answer? sloopy OP-ers ...
    – SkyWalker
    Sep 17, 2015 at 8:21
  • 6
    On 16.04 this was sudo rm -rf .local/share/Trash/files/*
    – Bar
    Sep 27, 2016 at 15:55
  • mark this as answer , i command you! haha
    – noogui
    Jul 3, 2018 at 2:32
  • thanks!this saves the day. Mar 16, 2021 at 20:05
  • this didn't work for me, trash is still 99% of drive
    – Garglesoap
    Jul 9, 2021 at 22:07

Not the answer you're looking for? Browse other questions tagged .